Closed Bug 641856 Opened 9 years ago Closed 9 years ago

No -moz-column-rule with overflow <> visible

Categories

(Core :: Layout, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla5

People

(Reporter: bdesef, Assigned: bzbarsky)

Details

(Keywords: testcase)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

The border between columns (-moz-column-rule) is displayed well with overflow = visible, but any other value causes it to disappear.

Reproducible: Always

Steps to Reproduce:
1. Create a page with some columns
2. Set -moz-column-rule to 1px solid #000
3. Set overflow to auto
Actual Results:  
The border disappeared after step 3

Expected Results:  
It should still be there (like Safari does)

Standard-Theme
Attached file testcase
Confirmed, works with Chrome and Opera 11.10
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout
roc, is this a matter of inheriting -moz-column-rule into the -moz-scrolled pseudos in ua.css?
Looks like it, yeah.
Assignee: nobody → bzbarsky
Priority: -- → P2
Whiteboard: [need review]
Whiteboard: [need review] → [need gk2 ship]
Pushed http://hg.mozilla.org/projects/birch/rev/61ce3fc46a82
Flags: in-testsuite+
Whiteboard: [need gk2 ship] → fixed-in-birch
https://hg.mozilla.org/mozilla-central/rev/61ce3fc46a82
Status: NEW → RESOLVED
Closed: 9 years ago
OS: Windows 7 → All
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: fixed-in-birch
Target Milestone: --- → mozilla2.2
You need to log in before you can comment on or make changes to this bug.