Improve the Windows Vista/7 progress bar glow effect

VERIFIED FIXED in mozilla6

Status

()

Core
Widget: Win32
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

Trunk
mozilla6
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

7 years ago
For the moment, the progress bar glow effect is taking into account the bar size but should take the entire progress bar size. It would make the effect less speedy and stressful ;)
(Assignee)

Comment 1

6 years ago
Created attachment 519938 [details] [diff] [review]
Patch v1

By tweaking the speed and adding a delay we seem to be close to what is usually done on Windows 7 (didn't check Vista but I assume it's not so far). Though, the speed and delay seems to vary between applications. I guess it's customizable.
Assignee: nobody → mounir.lamouri
Status: NEW → ASSIGNED
Attachment #519938 - Flags: review?(jmathies)
(Assignee)

Updated

6 years ago
Whiteboard: [needs review]
(Assignee)

Comment 2

6 years ago
(In reply to comment #0)
> For the moment, the progress bar glow effect is taking into account the bar
> size but should take the entire progress bar size. It would make the effect
> less speedy and stressful ;)

By the way, this comment is wrong. This is what Chrome is doing but that's not what Windows native widget does...
(Assignee)

Comment 3

6 years ago
Created attachment 519976 [details] [diff] [review]
Patch v1.1

With constants.
Attachment #519938 - Attachment is obsolete: true
Attachment #519938 - Flags: review?(jmathies)
Attachment #519976 - Flags: review?(jmathies)

Comment 4

6 years ago
Comment on attachment 519976 [details] [diff] [review]
Patch v1.1

Review of attachment 519976 [details] [diff] [review]:

r+
Attachment #519976 - Flags: review?(jmathies) → review+

Updated

6 years ago
Whiteboard: [needs review]
(Assignee)

Updated

6 years ago
Whiteboard: [ready to land][waits for dependencies]
(Assignee)

Comment 5

6 years ago
Pushed:
http://hg.mozilla.org/mozilla-central/rev/f8ab655d503c
http://hg.mozilla.org/mozilla-central/rev/4a7b8019b83f
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [ready to land][waits for dependencies]
Target Milestone: --- → mozilla6
(Assignee)

Comment 6

6 years ago
It's actually:
http://hg.mozilla.org/mozilla-central/rev/f645c3124254

Updated

6 years ago
Depends on: 655860
Backed out in http://hg.mozilla.org/mozilla-central/rev/dd9ba28d2bd9 to resolve bug 655860.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

6 years ago
The regression wasn't caused by these patches. Re-landed:
http://hg.mozilla.org/mozilla-central/rev/c15b58d50e45
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
No longer depends on: 655860

Comment 9

6 years ago
This broke something.  Now, when you download a file, the filled in green area does not take up the entire height of the bar and looks weird.  Screenshot provided.

Comment 10

6 years ago
Created attachment 531607 [details]
Download Window (green bar does not use entire height in 5/11/11 Nightly)

Comment 11

6 years ago
(In reply to comment #9)
> This broke something.  Now, when you download a file, the filled in green
> area does not take up the entire height of the bar and looks weird. 
> Screenshot provided.

I am using Build ID = http://hg.mozilla.org/mozilla-central/rev/a45b5cf1d625

Comment 12

6 years ago
(In reply to comment #9)
> This broke something.  Now, when you download a file, the filled in green
> area does not take up the entire height of the bar and looks weird. 
> Screenshot provided.

filed bug 656284.

Comment 13

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0

Everything seems in order now and bug 656284 got also fixed.

Setting status to Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.