WebifyMe has English strings in images

RESOLVED FIXED in 1.0

Status

P1
normal
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: ozten, Assigned: adam)

Tracking

({l12y})

unspecified
Dependency tree / graph

Details

(Reporter)

Description

8 years ago
Except for Mozilla and Firefox, images should not have words in them as this will create an L10n workload of editing images.

Please update images under static/img/en/ (or elsewhere) and remove copy.
Convert image into HTML and CSS that is "bulletproof" and can scale to any text.

So "GET A DOWNLOAD DAY REMINDER" is put into a div which can scale nicely to smaller and larger amounts of characters.
(Reporter)

Updated

8 years ago
Group: mozilla-corporation-confidential
(Reporter)

Comment 1

8 years ago
A small % of "objects" have English text in them.... 

Example: Crayon Box
internet_things/static/objects/large/1755_site_0050.png

Example: Hello my name is badge:
internet_things/static/feature_objects/1755_Site_0167.png

Might not be a big issue?
(Reporter)

Updated

8 years ago
Component: Other → Firefox for all
QA Contact: other → firefox-for-all
(Reporter)

Updated

8 years ago
Blocks: 642308
(Reporter)

Updated

8 years ago
Group: mozilla-corporation-confidential
(Reporter)

Updated

8 years ago
Assignee: nobody → chandler

Updated

8 years ago
Assignee: chandler → jbresnik
Keywords: l12y
Blocks: 650033

Updated

7 years ago
Assignee: jbresnik → claudia

Comment 2

7 years ago
In TBG's opinion, we're not finding this to be a big issue with the text in these two images. We recommend leaving as-is. If Mozilla feels strongly about it, we can address, but we think they are fine. Reassigning to Austin for final resolution.
Assignee: claudia → ozten.bugs
(Reporter)

Comment 3

7 years ago
So are the following images unused?
download_date.png            get_started_btn.png
download_day_header.png      get_started_sprite.png
download_day_reminder.png    get_your_results_sprite.png
download_firefox.png         header.png
download_firefox_sprite.png  make_your_own.png
ff4_presents.png             mozff4_presents.png
ff4_presents_white.png       mozff4_presents_white.png

I pointed out two images as examples of a broader concern....

They all have text that should be localized.
Even the ones with "Firefox 4" also have the word "presents". Firefox 4 is probably passable, but presents should be localizable.

thanks
Assignee: ozten.bugs → claudia

Updated

7 years ago
OS: Linux → All
Priority: -- → P1
Hardware: x86 → All
Target Milestone: --- → 1.0

Comment 4

7 years ago
Thanks, Austin - we'll definitely look into these.

Updated

7 years ago
Duplicate of this bug: 651581
(Assignee)

Updated

7 years ago
Assignee: claudia → adam
(Assignee)

Comment 6

7 years ago
Removed two spots where we had english strings in images today. I'm going to be looking at replacing make_your_own.png tomorrow, and whether we need any of the download day buttons anyway.
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
Strong work, thanks!
You need to log in before you can comment on or make changes to this bug.