Make correlation reports more useful (and move generation into Socorro)

RESOLVED DUPLICATE of bug 875990

Status

Socorro
General
RESOLVED DUPLICATE of bug 875990
7 years ago
5 years ago

People

(Reporter: Robert Kaiser, Assigned: rhelmer)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Q42011wanted] [Q12012wanted])

(Reporter)

Description

7 years ago
The current correlations tab of crash reports looks like some somewhat wonky script output has just been roughly glued into the nice web UI of Socorro - and I guess that's actually what it is in practice.

The correlation reports should be reworked to run inside Socorro itself, making use of the more modern and probably more performant architecture we have in place there now (I guess right now the script might run just out of the CSVs).

There's also some strange output happening in current reports at times (I saw some DLLs being reported as appearing in way over 100% of the reports, which sounds somewhat unrealistic), this should be addressed in this rework as well - and, of course, the output should be made more "webby" and easier to understand.


John J. Barton from Firebug, who is often looking for correlations of crashes with Firebug (naturally), also said this on my blog: 'Regarding the point about "correlations" page, I've never found that info to be useful, sorry. I have looked at it, but I don't recall every finding something useful.'
Maybe we can make the info useful to him as well (I'll let him describe why it's not right now), as he sounds like one of the major types of people that could make good use of correlations if they worked well.

Comment 1

7 years ago
Here's a couple of random crash reports.

https://crash-stats.mozilla.com/report/index/bp-12815adc-a508-4a8b-b984-c060e2110117
https://crash-stats.mozilla.com/report/index/bp-7cc9c801-461e-48ac-a323-ae99d2110223

If you look at the correlations you see boilerplate text and error messages. Pretty much what I always get. Thus, not useful.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> If you look at the correlations you see boilerplate text and error messages.
> Pretty much what I always get. Thus, not useful.

That's because those aren't reports for the most-current releases, and right now we only generate correlation reports for those. This should also change if it can be made an internal thing like this bug requests. :)
(In reply to comment #2)
> (In reply to comment #1)
> > If you look at the correlations you see boilerplate text and error messages.
> > Pretty much what I always get. Thus, not useful.
> 
> That's because those aren't reports for the most-current releases, and right
> now we only generate correlation reports for those. This should also change if
> it can be made an internal thing like this bug requests. :)

No, correlation reports are only generated each day for the three crashiest versions of a product (crashiest as measured over the past week ending on the day the reports are run); see bug 636233 and bug 628341 comment 7 et seq.  Given that, no 'pre' version is ever (barring some massive code screw-up) going to be crashy enough on a given day to generate a correlation report.

Hoever, even if the version is one of the 3 crashiest, the crashes signatures John is interested in (and the ones other add-on or even product vendors are interested in) may not be "crashy enough" to turn up in the correlations.

Bug 536649 might come into play for that second issue; there are certainly additional issues (beyond which versions to run the reports for) with small-sample apps/versions that will need to be worked out to make the correlations reports more useful to other-than-Firefox-stable-release-versions, but it's hard to guess what all they are until bug 629029 and bug 636233, at minimum, are resolved. !clone rhelmer ;)

I think, though, based on the info provided so far, that this bug is just a dupe of bug 636233 (and probably also bug 536649, or something like it).
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> I think, though, based on the info provided so far, that this bug is just a
> dupe of bug 636233 (and probably also bug 536649, or something like it).

No, those all are about some skewing around with the external-run analysis report that are stuck into the current UI in some hacky way, while this report is about doing a clean in-Socorro alternative (which of course should build on what the current stuff does) - but it's true that this might solve those other bugs on the way.
John's comment was just one more example of why the current ones are not what we want in the end.
(Reporter)

Updated

7 years ago
Summary: Make correlation reports more useful → Make correlation reports more useful (and move generation into Socorro)

Updated

7 years ago
See Also: → bug 650904
(Reporter)

Updated

7 years ago
Depends on: 650904
See Also: bug 650904

Updated

7 years ago
Whiteboard: Q42011wanted
Assignee: nobody → sneethling
Going to work on at least the UI aspects of this bug.
Status: NEW → ASSIGNED

Updated

7 years ago
Whiteboard: Q42011wanted → [Q42011wanted] [Q12012wanted]

Updated

7 years ago
Target Milestone: --- → 2.4.1
Component: Socorro → General
Product: Webtools → Socorro
Does it make sense to work on the UI for this before back-end changes has been made or, should there be a separate bug for the UI aspects that depends on this one?
(Reporter)

Comment 7

7 years ago
I think the back-end changes are the most important part, but those might be done mostly in bug 650904, not sure what the strategy is right now wrt what part will be done in which of those bugs.
We should have a UI refresh as well, of course, as the cut-out text fragments from the current report are not very Socorro-ish. I expect the data from the new reports to be the same, but come from a database via the middleware.
(Assignee)

Updated

7 years ago
Duplicate of this bug: 716044
Assignee: sneethling → nobody
No longer blocks: 716497
Created separate UI bug for correlations tab and targeted it to 2.4.2 based on [:laura] email.
Blocks: 716497

Updated

7 years ago
Target Milestone: 2.4.1 → 2.4.2

Updated

7 years ago
Assignee: nobody → chris.lonnen

Updated

7 years ago
Depends on: 722934

Updated

7 years ago
Depends on: 722936
Target Milestone: 2.4.2 → 2.4.3

Comment 10

7 years ago
mass migration of correlation-report related bugs that won't land today.

Updated

7 years ago
Target Milestone: 2.4.3 → 2.4.4

Updated

7 years ago
Target Milestone: 2.4.4 → 2.5.1

Updated

6 years ago
Target Milestone: 2.5.1 → 2.5.2

Comment 11

6 years ago
Kicking these out to 2.6, which roughly matches the next week I'll be working on Socorro. If someone wants to poach these to get them done earlier, that's fine with me.
Target Milestone: 2.5.2 → 2.6

Updated

6 years ago
Target Milestone: 4 → 6

Updated

6 years ago
Assignee: chris.lonnen → peterbe

Updated

6 years ago
Target Milestone: 6 → 7
Target Milestone: 7 → 8

Updated

6 years ago
Blocks: 524851
Target Milestone: 8 → 10
Target Milestone: 10 → 11
Target Milestone: 11 → Future
Assignee: peterbe → rhelmer
(Reporter)

Comment 12

6 years ago
One thing we should do is to explain the "X vs. Y" int hose reports, as I repeatedly get questions what that actually means.
(Assignee)

Comment 13

5 years ago
Work on this is actually happening over in bug 875990
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 875990
You need to log in before you can comment on or make changes to this bug.