Streamlining Minefield a bit more

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: rakshithbekal, Unassigned)

Tracking

({regression})

4.0 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110317 Firefox/4.0b13pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b13pre) Gecko/20110317 Firefox/4.0b13pre

A lot of space is wasted below minefield button when choosing small icons from the customize menu. So its better to eliminate wastage of space (a lot is wasted actually!) and make pages more viewable.

Reproducible: Always

Steps to Reproduce:
1.Open Minefield right choose customize 
2.and check "use small icons" in the option below
3.lot of pixels of space is wasted under the minefield button
Actual Results:  
Can see a lot of space wasted b/w minefield button and the location bar.

Expected Results:  
adopted changes to small icon's option by eliminating the free space left below minefield button (reverts back when usual icon settings are opted)
(Reporter)

Comment 1

8 years ago
Created attachment 520181 [details]
wasted space in "red"
Component: General → Theme
QA Contact: general → theme

Updated

8 years ago
Blocks: 570279
Keywords: regression

Comment 2

8 years ago
Just my two cents: There is no "wasted" space and I don't want Firefox to be streamlined to death. 

The "wasted" space is because of the height of the tabs. The UI team has decided that this is the appropriate height. To make those gaps mentioned above smaller, you would have to make the tabs smaller which, in my opinion looks bad.

Comment 3

8 years ago
Created attachment 520443 [details]
Smaller tabs in a maximized window

This is the look you could get to have smaller gaps under the app-button in a maximized window under Windows 7. I think this odd look is not worth the saved pixels at all.
(Reporter)

Comment 4

8 years ago
Yeah I'm Not sure. Maybe a little deduction would be better than completely using the space.

Comment 5

7 years ago
different sizes of tab bar in different modes would break consistency

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 6

7 years ago
It isn't exactly wasted space, since that dragging in that space will move/restore the window.

Changing the height of tabs in different modes is bad for visual consistency. Also, the reduction of white space makes the toolbar makes it feel more crowded not streamlined.

The balance in horizontal and vertical margins/padding will be improved in the ongoing visual refresh. Follow along with the design evolution here: http://stephenhorlander.com/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

7 years ago
(In reply to Frank Yan [:fryn] from comment #6)
> It isn't exactly wasted space, since that dragging in that space will
> move/restore the window.
> 
> Changing the height of tabs in different modes is bad for visual
> consistency. Also, the reduction of white space makes the toolbar makes it
> feel more crowded not streamlined.
> 
> The balance in horizontal and vertical margins/padding will be improved in
> the ongoing visual refresh. Follow along with the design evolution here:
> http://stephenhorlander.com/

I agree
You need to log in before you can comment on or make changes to this bug.