Facebook occasionally complains "URL is not properly formatted"

RESOLVED INVALID

Status

RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: clarkbw, Unassigned)

Tracking

Details

== copied from https://github.com/mozilla/f1/issues#issue/90 ==

Attempt to share: http://www.the-requiem.cz.cc/2011/03/east-jesus-nowhere.html

Facebook's response:

5:17:50,615 INFO  [linkdrop-metrics] [worker 1] domain='facebook.com' short_url=None when=130033547.6159999 remote_address='127.0.0.1' message_len=5 took=1.0033934480499624 acct_id='xxx' long_url='http://www.the-requiem.cz.cc/2011/03/east-jesus-nowhere.html' eror={'status': 400, u'message': u'(#100) link URL is not properly formatted', 'code': 0, u'type': u'AuthException', 'provider': 'facebook.com'} id='send-error'

The above seems reproducible (ie, was not transient). Ditto for the ftp site listed below (but the http version of that mozilla page shares OK)

Other URLs in the log with the same error:

http://www.noroeste.com.mx/publicaciones.php?id=669120
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/4.0rc1-candidates/build1/win32/en-US/
http://apptrackr.org/?act=viewapp&appid=351733272
http://www.alzalam.tk/vb/showthread.php?t=235
file:///C:/Documents%20and%20Settings/Mecanifoz/Ambiente%20de%20trabalho/comissaoaooo.html (heh!)

Comments
davidascher

iiuc, these are all fine URLs that just trip up facebook's url detector? we should likely file them downstream...

mhammond

Not sure what you mean by "fine URL" but looking a little deeper:

http://www.the-requiem.cz.cc/2011/03/east-jesus-nowhere.html returns a 404 but with text/html content (Firefox shows it fine)

The rest of the http:// URLs all seem normal - they give 200 responses and a text/html content-type.

Agreed we should filter out ftp:// and file:// schemes, but we probably just want a whitelist of schemes we do support.
My guess is that Facebook is getting a 404 on the link, and refusing to share it.  I get an error on Facebook if I try to share the url.  We should check the status code when deciding if it is a valid url to share.
We can get the status via:

contentBrowser.docShell.currentDocumentChannel.QueryInterface(Ci.nsIHttpChannel).responseSTatus

The question is, do we want to disallow sharing 404 pages?  Sometimes there are cool 404 pages to share, it's just Facebook failing on it.
(Reporter)

Comment 3

8 years ago
protz reported seeing the same error with this link (I can confirm that Jean can't share that either):

http://www.universalsubtitles.org/en/videos/NNxEqfuQSaPN/info/Mozilla%20Firefox:%20A%20Different%20Kind%20of%20Browser/
The problem in that page is caused by the meta tag we read:

meta property="og:image" content="http://www.universalsubtitles.orghttp://s3.www.universalsubtitles.org/images/small_logo.png"

note the invalid url.  This is covered in bug 644013.
(In reply to comment #0)
> == copied from https://github.com/mozilla/f1/issues#issue/90 ==
> 
> Other URLs in the log with the same error:
> 
> http://www.noroeste.com.mx/publicaciones.php?id=669120
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/4.0rc1-candidates/build1/win32/en-US/
> http://apptrackr.org/?act=viewapp&appid=351733272
> http://www.alzalam.tk/vb/showthread.php?t=235
> file:///C:/Documents%20and%20Settings/Mecanifoz/Ambiente%20de%20trabalho/comissaoaooo.html
> (heh!)

None of those urls are shareable directly on facebook itself, and no reason is given.  Facebook gives us a generic error incorrectly claiming in some circumstances that the url is malformed, but I cannot see any reason for that.  I've a feeling they are blacklisting some sites for some reason.
Component: Server: Share → F1
Product: Mozilla Services → Mozilla Labs
QA Contact: share-server → f1
(Reporter)

Comment 6

6 years ago
f1 is no longer an active project.  delete these messages by searching for: [closing_f1_project_bugs]
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.