Last Comment Bug 643167 - Spidermonkey configure should build js-config with MAKE, not GMAKE
: Spidermonkey configure should build js-config with MAKE, not GMAKE
Status: RESOLVED FIXED
[pymake]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 2.0 Branch
: All Windows 7
: -- normal (vote)
: mozilla11
Assigned To: Ed Morley [:emorley]
:
Mentors:
: 667579 707511 (view as bug list)
Depends on:
Blocks: 605133
  Show dependency treegraph
 
Reported: 2011-03-19 13:05 PDT by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2011-12-09 06:56 PST (History)
6 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.63 KB, patch)
2011-03-19 13:34 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
ted: review-
Details | Diff | Review
Patch v2 (2.66 KB, patch)
2011-12-04 11:20 PST, Ed Morley [:emorley]
ted: review+
Details | Diff | Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2011-03-19 13:05:12 PDT
creating js-config.h
invoking make to create js-config script
make.exe[1]: Entering directory `/z/dev/build-rebuild/obj-i686-pc-mingw32/js/src
'
config/autoconf.mk:354: *** Windows-style srcdir being used with GNU make. Did y
ou mean to run z:/dev/build-rebuild/js/src/build/pymake/make.py instead? [see-al
so: https://developer.mozilla.org/en/Gmake_vs._Pymake].  Stop.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-03-19 13:34:19 PDT
Created attachment 520466 [details] [diff] [review]
Patch
Comment 2 Benjamin Smedberg [:bsmedberg] 2011-03-21 06:41:37 PDT
Hrm, when I did this originally I used gmake very specifically on purpose. I don't remember why it was necessary, though, so perhaps the reason is moot. Have you tried it with a client.mk-style build?
Comment 3 Ted Mielczarek [:ted.mielczarek] 2011-03-24 10:23:31 PDT
pbiggar changed this in the mega-patch in bug 605133, but I don't recall why. (He and I went through all the changes together at one point.) It probably has to do with syncing this bit from the top-level makefile:
http://hg.mozilla.org/mozilla-central/rev/b1094f628602#l1.601
Comment 4 Paul Biggar 2011-03-24 10:46:45 PDT
(In reply to comment #1)
> Created attachment 520466 [details] [diff] [review]
> Patch

The MAKE->GMAKE change was to fix cross-compilation, see bug 605133 comment 22. Best to check that it still works before pushing this.
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-03-24 11:36:03 PDT
Boris Zbarsky (:bz) 2010-10-29 14:05:00 PDT

This (as determined by local bisect) seems to have broken my ability to build
32-bit shell builds on Mac:

js/src/opt-obj-32% rm -rf * && ( cd .. && autoconf213 ) && env CC="gcc-4.2
-arch i386" CXX="g++-4.2 -arch i386" AR=ar CROSS_COMPILE=1 ../configure
--enable-optimize --disable-debug --target=i386-apple-darwin9.2.0
--enable-macos-target=10.5 --enable-shark
....
invoking make to create js-config script
../configure: line 16054: js-config: command not found

This leads me to believe that MAKE was not set in his environment.  Since I'm setting MAKE in client.mk, that shouldn't be a problem.

And if we break it I'm sure Boris will let us know ;-)
Comment 6 Paul Biggar 2011-03-24 11:49:19 PDT
(In reply to comment #5)
> This leads me to believe that MAKE was not set in his environment.  Since I'm
> setting MAKE in client.mk, that shouldn't be a problem.

client.mk is not used for a shell build.


> And if we break it I'm sure Boris will let us know ;-)

Please test it first. You're reverting a change that was specifically put in to a fix Boris' problem. Checking that you don't regress the problem is surely a requirement for checking this in.
Comment 7 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-03-24 11:50:57 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > This leads me to believe that MAKE was not set in his environment.  Since I'm
> > setting MAKE in client.mk, that shouldn't be a problem.
> 
> client.mk is not used for a shell build.

Ah, that's a good point.
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-03-24 11:52:18 PDT
So I think we want to use GMAKE if MAKE is not defined then.
Comment 9 Ted Mielczarek [:ted.mielczarek] 2011-03-25 05:12:49 PDT
Comment on attachment 520466 [details] [diff] [review]
Patch

r- till you prove that you're not breaking standalone js builds.
Comment 10 Joey Armstrong [:joey] 2011-08-18 13:28:11 PDT
*** Bug 667579 has been marked as a duplicate of this bug. ***
Comment 11 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-04 08:21:49 PST
*** Bug 707511 has been marked as a duplicate of this bug. ***
Comment 12 Ed Morley [:emorley] 2011-12-04 11:20:43 PST
Created attachment 578926 [details] [diff] [review]
Patch v2

(Kyle, hope you don't mind me taking).

As previous patch, but also sets $MAKE to $GMAKE if it's not defined, so as to avoid Boris' problem with standalone js builds (a la bug 605133 comment 22). Solves the pymake problem in comment 0 / bug 707511 for me locally. Will get Boris to test standalone js builds with this applied before landing.

https://tbpl.mozilla.org/?tree=Try&rev=11a0cf64e403
Comment 13 Ted Mielczarek [:ted.mielczarek] 2011-12-06 14:55:23 PST
Comment on attachment 578926 [details] [diff] [review]
Patch v2

Review of attachment 578926 [details] [diff] [review]:
-----------------------------------------------------------------

As long as this doesn't break anyone, fine with me.
Comment 14 Ed Morley [:emorley] 2011-12-08 12:21:09 PST
(bz confirmed this didn't break his js shell builds)

https://hg.mozilla.org/integration/mozilla-inbound/rev/758a0ae33484
Comment 15 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-08 12:21:45 PST
Thanks for taking this on.
Comment 16 Ed Morley [:emorley] 2011-12-09 06:56:19 PST
https://hg.mozilla.org/mozilla-central/rev/758a0ae33484

Note You need to log in before you can comment on or make changes to this bug.