Closed Bug 643225 Opened 11 years ago Closed 11 years ago

Browser crashes [@ libc.so@0x133e6 ] sometimes on opening www.qq.com on Motorola Xoom

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: webqa.utest, Unassigned)

References

()

Details

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.151 Safari/534.16
Build Identifier: Mozilla/5.0 (Android; Linux armv71; rv:2.1) Gecko/20110318 Firefox/4.0b13pre Fennec/4.0

Device Model: Motorola Xoom
OS version: 3.0
Carrier: Telstra
WiFi/3G/4G: WiFi & 3G

Reproducible: Sometimes

Steps to Reproduce:
1) Launch the browser
2) launch baidu.com
3) then launch qq.com

Repeat this several times

Sometimes just happens on launching qq.com
Actual Results:  
The browser crashes sometimes

3 out of 10 times. Logs sent to firefox

Expected Results:  
the browser should not crash

Utest Bug id# 131175
Can you post the breakpad id?
https://crash-stats.mozilla.com/report/index/bp-487cfb92-9fdd-422f-87a8-acac32110321
0  	libc.so  	libc.so@0x133e6  	
1 	libc.so 	libc.so@0x39901 	
2 	libc.so 	libc.so@0x14714 	
3 	libc.so 	libc.so@0x196b6 	
4 	libc.so 	libc.so@0x39864 	
5 	libc.so 	libc.so@0x19ae4 	
6 	libc.so 	libc.so@0x1875a 	
7 	libc.so 	libc.so@0x39864 	
8 	libc.so 	libc.so@0x39879 	
9 	libc.so 	libc.so@0x314be 	
10 	libc.so 	libc.so@0x39864 	
11 	libc.so 	libc.so@0x39876 	
12 	libc.so 	libc.so@0x39879
Summary: Browser crashes sometimes on opening www.qq.com on Motorola Xoom → Browser crashes [@ libc.so@0x133e6 ] sometimes on opening www.qq.com on Motorola Xoom
Strange things about the crash report:
- over 340 threads active
- the crashing thread is not the main thread and doesn't appear to show anything useful
WFM on droid 2  (I have no plugins installed):
Mozilla/5.0 (Android; Linux armv71; rv2.0b13pre) Gecko/20110323 Firefox/4.0b13pre Fennec/4.1a1pre
Device: Droid 2 
OS: Android 2.2

Not sure if it's machine specific?
I am not able to reproduce it on HTC Desire Z (Android 2.2)

Build ID: Mozilla /5.0 (Android;Linux armv7l;rv:5.0a2) Gecko/20110414 Firefox/5.0a2 Fennec /5.0a2 

webqa.utest, can you still reproduce it ?
I can't reproduce in Xoom Android 3.0.1 
Build ID: Mozilla/5.0 (Android;Linux armv7l;rv:2.1.1)Gecko/20110415 Firefox/4.0.2pre Fennec /4.01
WFM

Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110515 Firefox/6.0a1 Fennec/6.0a1 


Mozilla /5.0 (Android;Linux armv7l;rv:5.0a1) Gecko/20110515 Firefox/5.0a2 Fennec/5.0a2 

Device: HTC Desire Z (Android 2.2)
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Still seems to occur on build ID 20110614175350:
on motorola MZ601 and Motorola MZ604

See More Reports:
https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-06-21%2008%3A00%3A00&signature=libc.so%400x133e6&version=Fennec%3A5.0
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
As libc.so has been added to the Socorro skiplist, there's no longer a crash signature.
In addition, per comment 8, I close it as workforme.
Status: REOPENED → RESOLVED
Crash Signature: [@ libc.so@0x133e6]
Closed: 11 years ago11 years ago
OS: Other → Android
Hardware: Other → ARM
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.