Closed Bug 643277 Opened 10 years ago Closed 10 years ago

TI: Assertion failure: !unknownProperties, at ../jsinferinlines.h:1134

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 643249

People

(Reporter: decoder, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

The following code (run with -n -a -m) causes an assert on TI tip (tested on 64 bit):

function arrayEvery(arr, fun)
{
  return Array.prototype.every.call(arr, fun);
}
function arraysEqual(a1, a2)
{
  return a1.length === a2.length &&
         arrayEvery(a1, function(v, i) { return v === a2[i]; });
}
var obj = {};
function strictArgs(a)
{
  return arguments;
}
assertEq(arraysEqual(strictArgs(1, obj), [1, obj]), true);
{
}
function strictEval(code, p)
{
  return arguments;
}
assertEq(arraysEqual(strictEval("1", 2), ["1", 2]), true);
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 643249
A testcase for this bug was already added in the original bug (bug 643249).
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.