Closed Bug 643311 Opened 10 years ago Closed 10 years ago

html5 audio tag bug; can not stream .nsv

Categories

(Core :: Audio/Video, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED WONTFIX

People

(Reporter: bassmann, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Iron/10.0.650.0 Chrome/10.0.650.0 Safari/534.16
Build Identifier: 4.0

when i try to stream for example:
<audio controls>
<source src="hxxp://shoutcast.*****.org:8000/;stream.nsv" />
</audio>

nothing happens.
the controls load but then nothing all other browser (chrome ie9) had no problems with that.
I hope this could be fixed

Reproducible: Always

Steps to Reproduce:
1.start the html file
2.wait
3.wait
Actual Results:  
nothing

Expected Results:  
play the stream
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Do you have a plugin installed to help with that .nsv file (Nullsoft Streaming Video) ? Maybe the one from Winamp ? The browser can't do it on its own ...
We have no plans to support the NSV container at this time.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
@ chris pearce: i think this is no realy big problem
when i start this it load but then it stop after a wile 
([21:29:54.151] GET http://shoutcast.****.org:8000/;stream.nsv [ 250ms])
so i thin the problem is tha ff await a complete file, the other browsers buffer and play there it doesen´t matter if there is a ending

@jo Hermans: isn´t it the sense of html5 that you do note need plugins any more?
[edit]
nsv isn´t a container its just an mpeg stream
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
We have no plans to support the MPEG container either.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → WONTFIX
(In reply to comment #3)
> @jo Hermans: isn´t it the sense of html5 that you do note need plugins any
> more?

You can't expect that the browser can understand *every* audio and video format that is out there. Unless everyone uses the same one (but Html5 doesn't mandate any codec at all), you would still need a plugin or a similar mechanism to help support the codec. <insert-the endless-debate-about-ogg-theora-and-h264-and-webm>
I don't want the browser do everything for me, like making my coffee while i'm waiting for an slow website, but i thought it could handle a stream like this, cause the others (like ie9[wow for that] and chrome) can, so my first opinion was: "This is a bug!"
 
For checking there is no misunderstanding, an completed mp3 file works fine, but an endless-stream-file (whatever) with the same codec is not supported from the FireFox in his HTML5-Audio-Control??
 
That makes definetly no sense for me!
(In reply to comment #7)
> For checking there is no misunderstanding, an completed mp3 file works fine,
> but an endless-stream-file (whatever) with the same codec is not supported from
> the FireFox in his HTML5-Audio-Control??

MP3 is not supported in Firefox. HTML5 <audio> in Firefox will not play MP3. If you're able to play MP3 in HTML5 <audio> with Firefox, then you've got some third party plugin which is playing it for you. Firefox cannot natively play MP3s. You should file a bug with your third party plugin provider regarding the inability to play non-completed MP3/MPEG/NSV streams.
oh sorry after third check i sawn that my vlc play the mp3 (with the control buttons wich look nearly the same like the other browsers
sorry for that.
I don´t want an completly discousion about mp3 and this can a broser handle and this not but why not mp3? i mean there is no discousion about standart file or what else.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.