Closed Bug 643515 Opened 9 years ago Closed 9 years ago

Firefox 4.0 Crash [@ mozilla::dom::PAudioParent::CreateSharedMemory(unsigned int, mozilla::ipc::SharedMemory::SharedMemoryType, bool, int*) ]

Categories

(Core :: Plug-ins, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 640901

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

Seen while reviewing chofmann's report from Friday. All the comments mention Adobe Reader and opening a PDF. http://tinyurl.com/4v99sah to the reports last week which are all Windows.

https://crash-stats.mozilla.com/report/index/ae3bef7c-225f-4cc1-b485-b27072110320

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	mozilla::dom::PAudioParent::CreateSharedMemory 	obj-firefox/ipc/ipdl/PBrowserChild.cpp:1444
1 	xul.dll 	mozilla::plugins::PPluginInstanceParent::RemoveManagee 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:2061
2 	xul.dll 	mozilla::plugins::PPluginScriptableObjectParent::OnMessageReceived 	obj-firefox/ipc/ipdl/PPluginScriptableObjectParent.cpp:613
3 	xul.dll 	mozilla::plugins::PPluginModuleParent::OnMessageReceived 	obj-firefox/ipc/ipdl/PPluginModuleParent.cpp:528
4 	xul.dll 	mozilla::ipc::AsyncChannel::OnDispatchMessage 	ipc/glue/AsyncChannel.cpp:262
5 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:244
6 	xul.dll 	mozilla::plugins::PPluginScriptableObjectParent::CallInvalidate 	obj-firefox/ipc/ipdl/PPluginScriptableObjectParent.cpp:119
7 	xul.dll 	mozilla::plugins::PluginScriptableObjectParent::ScriptableInvalidate 	dom/plugins/PluginScriptableObjectParent.cpp:117
8 	xul.dll 	NPObjWrapperPluginDestroyedCallback 	modules/plugin/base/src/nsJSNPRuntime.cpp:1925
9 	xul.dll 	PL_DHashTableEnumerate 	obj-firefox/xpcom/build/pldhash.c:754
10 	xul.dll 	nsJSNPRuntime::OnPluginDestroy 	modules/plugin/base/src/nsJSNPRuntime.cpp:1992
11 	xul.dll 	nsNPAPIPluginInstance::InitializePlugin 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:426
12 	xul.dll 	nsNPAPIPluginInstance::Initialize 	modules/plugin/base/src/nsNPAPIPluginInstance.cpp:150
13 	xul.dll 	nsPluginHost::TrySetUpPluginInstance 	modules/plugin/base/src/nsPluginHost.cpp:1383
14 	xul.dll 	nsPluginHost::SetUpPluginInstance 	modules/plugin/base/src/nsPluginHost.cpp:1264
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 640901
Crash Signature: [@ mozilla::dom::PAudioParent::CreateSharedMemory(unsigned int, mozilla::ipc::SharedMemory::SharedMemoryType, bool, int*) ]
You need to log in before you can comment on or make changes to this bug.