Closed Bug 643836 Opened 9 years ago Closed 9 years ago

Invalidation does not always trigger a displayport update

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 4.0.1+ ---

People

(Reporter: stechz, Assigned: stechz)

Details

(Keywords: mobile)

Attachments

(1 file)

The problem is that we were invalidating for the visual overflow rect when we should be accounting for the displayport. This is overshadowed by Fennec redrawing everytime a scroll is finished, but it causes us to unnecessarily checkerboard in some cases until the pan is finished.
Ironically, I forgot to adjust the invalidation for any displayport.
Attachment #521005 - Flags: review?(tnikkel)
Assignee: nobody → ben
tracking-fennec: --- → ?
Keywords: mobile
Comment on attachment 521005 [details] [diff] [review]
Invalidation does not always trigger a displayport update

A few lines are way past 80 chars long.
Attachment #521005 - Flags: review?(tnikkel) → review+
Will fix that and extra space on landing.
Whiteboard: [fennec-4.1?]
Whiteboard: [fennec-4.1?] → [fennec-4.1?] [fennc-rc2?]
Pushed http://hg.mozilla.org/mozilla-central/rev/070a9c6209b3

Should I leave open since this may be a ridealong for any potential RC2?
Whiteboard: [fennec-4.1?] [fennc-rc2?] → [4.0.1?]
tracking-fennec: ? → 4.0.1+
We can move this to branch for 4.0.1
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [4.0.1?]
landed on mozilla-2.1 -- 0a6405a47498
Any exemplary methods for verifying the invalidation improvement?
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.