fonts appear choppy / light on linux

RESOLVED DUPLICATE of bug 458612

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 458612
7 years ago
7 years ago

People

(Reporter: davidsteiner2010, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-2011-05-06], URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.15) Gecko/20110303 Ubuntu/10.10 (maverick) Firefox/3.6.15
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0

the fonts don't look as good and is harder to read as in firefox 3.6.

the different is clearly visible in the URL. on the left side we see firefox 4.0. on the right is firefox 3.6.15.

Reproducible: Always




Tested on Ubuntu 10.10 (fresh install a couple of days ago). No crucial changes were made to the configuration (all defaults regarding appearance).
(Reporter)

Comment 1

7 years ago
Created attachment 521015 [details]
screenshot showing the difference in font rendering (ff 4.0 versus 3.6)
(Reporter)

Comment 2

7 years ago
installing this ppa seems to fix the font rendering: 
https://launchpad.net/~mozillateam/+archive/firefox-stable

Comment 3

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

I cannot observe the issue you have logged when comparing the two browser versions.

Am I to understand from Comment 2 that the issue is no longer present?
Version: unspecified → Trunk
(Reporter)

Comment 4

7 years ago
"Am I to understand from Comment 2 that the issue is no longer present?"

It's still present in the version downloaded from firefox.com.
It's fixed in the version from the Ubuntu Firefox maintainers (the above link).
(In reply to comment #4)
> It's still present in the version downloaded from firefox.com.
> It's fixed in the version from the Ubuntu Firefox maintainers (the above link).

I can confirm this.
Fonts in the version downloaded from mozilla.com looked really bad. The one from the Launchpad PPA looks much better! Basically the same as 3.6.

Is it due to different compile options mentioned here: http://www.dwasifar.com/?p=1473 ?
(Reporter)

Comment 6

7 years ago
that could be it. about:buildconfig from the Launpad PPA has these options:

--enable-default-toolkit=cairo-gtk2
--disable-system-cairo

maybe these should be set on the official ff build?

here are all the build options:

--build=x86_64-linux-gnu --prefix=/usr --localstatedir=/var --libexecdir=/usr/lib/firefox-4.0 --disable-maintainer-mode --disable-dependency-tracking --disable-silent-rules --srcdir=/build/buildd/firefox-4.0+nobinonly/build-tree/mozilla --disable-elf-dynstr-gc --disable-install-strip --disable-strip --disable-updater --enable-application=browser --enable-default-toolkit=cairo-gtk2 --enable-startup-notification --enable-pango --enable-svg --enable-mathml --enable-safe-browsing --with-distribution-id=com.ubuntu --without-system-jpeg --without-system-png --without-system-zlib --enable-chrome-format=omni --enable-optimize --enable-ipc --enable-tests --enable-mochitest --enable-ipdl-tests --disable-system-cairo --without-system-nspr --without-system-nss --disable-system-sqlite --disable-system-hunspell --enable-crashreporter --enable-official-branding --enable-gnomevfs --disable-gio --disable-debug

Comment 7

7 years ago
As far as I know, Ubuntu uses its own fonts. You only have to know the configuration to enable it.
Whiteboard: [bugday-2011-05-06]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458612
You need to log in before you can comment on or make changes to this bug.