Last Comment Bug 644209 - i18n tests assume they can load non-UTF from chrome:// URIs
: i18n tests assume they can load non-UTF from chrome:// URIs
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Simon Montagu :smontagu
:
Mentors:
Depends on:
Blocks: 617339
  Show dependency treegraph
 
Reported: 2011-03-23 10:08 PDT by Boris Zbarsky [:bz]
Modified: 2012-05-25 08:30 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (5.95 KB, patch)
2012-05-24 08:44 PDT, Simon Montagu :smontagu
VYV03354: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] 2011-03-23 10:08:14 PDT
When I checked in the patch for bug 617339, a bunch of intl tests (browser/docshell/test/browser/browser_bug92473.js and a variety of stuff in extensions/universalchardet) broke, because they expect to be loading non-UTF8 stuff from chrome:// URIs.  Can we switch these tests to use file:// URIs instead or something?
Comment 1 Boris Zbarsky [:bz] 2012-05-23 21:07:28 PDT
Simon, ping?
Comment 2 Simon Montagu :smontagu 2012-05-24 08:44:03 PDT
Created attachment 626825 [details] [diff] [review]
Patch
Comment 4 Simon Montagu :smontagu 2012-05-24 12:58:25 PDT
... and https://hg.mozilla.org/integration/mozilla-inbound/rev/d26f6917e986 to pick up some polish changes that I made after pushing to try and before review

Note You need to log in before you can comment on or make changes to this bug.