Closed Bug 644234 Opened 10 years ago Closed 10 years ago

Problems of the new download addon interface

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 643020

People

(Reporter: Delineif, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0

In firefox 4, addon downloading is moved to the url bar. There's no longer a separate window.
If you switch to another tab, or even click somewhere in the same window, that dialog disappears (it is minimized in url bar, but it's the same icon as AMO, so it is really easy to miss, unless you already know it is there).
The user is unhappy that he can't browse other pages while the addon downloads. He tries several times and finally stops waiting with the download in foreground. Some time later, he gets many dialogs asking to 
install the same addon.
Not only is it counterintuitive, but if he *closed* the tab, the downloading process still continues in the background, with no way to stop it (the 'downloading addon' icon is not kept accross tabs).


Reproducible: Always
Blocks: 570012
Component: Theme → General
OS: Linux → All
QA Contact: theme → general
Hardware: x86_64 → All
Version: unspecified → Trunk
I think this UI is being reworked.
Yeah we're going to be changing this a lot so just going to dupe this to the bug that will track that effort.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 643020
You need to log in before you can comment on or make changes to this bug.