When opening a new tab the background color is white at first no matter which settings are used

RESOLVED DUPLICATE of bug 558585

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 558585
7 years ago
7 years ago

People

(Reporter: eMail, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110321 Firefox/4.0

I use a dark color scheme on my system to be nice to my eyes. When I open a new tab in Firefox 4.0 the background of the new tab flashes white for a moment and only changes to the correct darker background color when the content of the new tab starts rendering.

I already tried to set browser.display.background_color to a dark value and disabled browser.display.use_system_colors as was told in the description of browser.display.background_color but it did not solve the problem.

Reproducible: Always

Steps to Reproduce:
0. Make sure you have set a dark background color.
1. Open Firefox 4.0.
2. Make sure all tabs are closed except one.
3. Open a new tab by clicking the little + sign.
Actual Results:  
The background of the newly opened tab flashes white for a moment and then changes to the configured dark background color.

Expected Results:  
The background of the new tab should be rendered in the configured dark color from the very beginning.

Comment 1

7 years ago
Similar to bug 644874?

Updated

7 years ago
Duplicate of this bug: 644874

Comment 3

7 years ago
I confirm this behaviour, and that its very irritating. Its VERY evident when using vimperator/pentadactyl, since new tabs are opened in the foreground by default. Also very evident on slower internet speeds (high-latency parts of the world). This did not occur in firefox 3.x

Comment 4

7 years ago
Confirmed on Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110329 Firefox/4.2a1pre

Clicking on a new tab button, there is a white flash in the background for a moment and then it opens the tabs as per the background colour.

Comment 5

7 years ago
Could you try and find the regression range if possible, please:
http://harthur.github.com/mozregression/
Status: UNCONFIRMED → NEW
Component: General → Theme
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
QA Contact: general → theme
Version: unspecified → Trunk

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558585

Updated

7 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.