Closed Bug 644392 Opened 9 years ago Closed 4 years ago

Flash ExternalInterface methods no longer accept JS arrays, only Strings (FF 4.0)

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: matt, Unassigned)

References

()

Details

(Keywords: regression, testcase-wanted, Whiteboard: [bugday-2011-05-27][js-triage-needed])

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16
Build Identifier: Firefox 4.0

A SWF file can expose methods for Javascript to call. These are called ExternalInterfaces.  One can pass javascript types, including arrays and arrays of arrays, into these ExternalInterface methods.

In every browser I have tried, including Firefox 3.6.15, Chrome 10, Safari 5.0.4, and IE8, this functionality works as expected.  However, Firefox 4.0 will only accept string values.  It will not accept arrays, as other browsers do.

Reproducible: Always

Steps to Reproduce:
1. Log into carbonexploration.cloud-spring.com
2. Add some items to your profile by dragging them from the left palette into the middle of the screen.  Add several different types of items.
3. Click on the "Explore" tab and see a large SWF load up.

Actual Results:  
You don't see graphs, though you do see text labels.  The label text is passed in via ExternalInterface calls as Strings.  The data that drives the graphs is passed in as 2D arrays of Strings.

Expected Results:  
You should see some horizontal bar graphs with your carbon footprint data.

It should have rendered graphs.  I have ascertained that the data for the graphs is indeed making it to the Javascript the pushes the array data into the SWF via Javascript.
Summary: Flash ExternalInterface methods no longer accept arrays, only Strings → Flash ExternalInterface methods no longer accept JS arrays, only Strings (FF 4.0)
Would you be able to try and find the regression range:
http://harthur.github.com/mozregression/
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
I have confirmed this bug on FF4.0 for WinXP too.

I will work on regressing it.
Also OS X 10.6.
OS: Mac OS X → Windows XP
Matt, any luck with the regression range?

Does it still occur using 4.0.1 or perhaps using the latest nightly?
Matt, have you found any regression range yet?
Whiteboard: [bugday-2011-05-27]
I am still seeing this issue on FF 5.0.1
Any news about this issue?
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:8.0a1) Gecko/20110809 Firefox/8.0a1 ID:20110809030751

WFM against:
Opera/9.80 (Windows NT 5.1; U; Edition Next; en) Presto/2.9.186 Version/12.00
Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/15.0.847.0 Safari/535.1

Will do some Regrange Hunting later on ...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Against TM repo:

Last good nightly: 2010-12-30
First bad nightly: 2010-12-31

Pushlog:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=7afbb62b190b&tochange=8dc385ffb820
Assignee: nobody → general
Component: Plug-ins → JavaScript Engine
QA Contact: plugins → general
Is it possible to get a contained testcase for this that doesn't involve a login screen? The TM regression range doesn't have any obvious suspects, and I've verified that at least in basic tests it is possible to pass JS arrays through the NPAPI boundary still.
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [bugday-2011-05-27] → [bugday-2011-05-27][js-triage-needed]
FWIW, I created a Testaccount on the Site what exposes the Issue:
L: Bug644392
P: mozilla
@bsmedberg is the account info provided by comment 12 sufficient?
Keywords: testcase-wanted
The URL provided in the description isn't available anymore. I've tried both on the latest Nightly (20130111030906) and Chrome.

Is there another URL that I can test with?
Flags: needinfo?(matt)
The site I found it with is no longer active, sorry.
Flags: needinfo?(matt)
Unfortunately, I don't think there's much QA can do without a reproducible website or minimized testcase. Please re-add qawanted if/when this can be provided.
Keywords: qawanted
Assignee: general → nobody
Hi,

Based on comment 14 and comment 15 I will mark this issue as Resolved-Incomplete. If you find an URL where this issue is reproducible please feel free to reopen this bug.

Thanks,
Cipri
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.