Closed Bug 644455 Opened 11 years ago Closed 11 years ago

Focus event not fired on document on last shift+tab before leaving document

Categories

(Core :: Disability Access APIs, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 618046

People

(Reporter: Jamie, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Str:
1. Open http://google.com/cow/
2. Tab to the link.
3. Press shift+tab to move focus to the document.
Expected: The link should lose the focused state and a focus event should be fired on the document.
Actual: The link loses the focused state, but no focus event is fired on the document.
Note: The document should probably also gain the focused state, but this seems to break in other cases as well, so that is probably a separate bug.

This also occurs with applications such as the Add-ons Manager.

Tested with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre. However, this also occurs in Firefox 3.6, although the link doesn't lose the focused state there.
Adjusting summary to cover the fact that this also occurs when shift+tabbing out of iframe documents.
Summary: Focus event not fired on document on last shift+tab before Navigation toolbar → Focus event not fired on document on last shift+tab before leaving document
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618046
You need to log in before you can comment on or make changes to this bug.