Closed Bug 64447 Opened 24 years ago Closed 23 years ago

Images on a Web page keep printing on separate pages so I wind up wasting paper

Categories

(Core :: Printing: Output, defect)

defect
Not set
normal

Tracking

()

VERIFIED WORKSFORME
mozilla1.0

People

(Reporter: bijals, Assigned: karnaze)

References

()

Details

Steps:
1) Open Navigator
2) Go to http:///www.businessweek.com
3) Click FILE - PRINT

Actual Results: Notice that when you go to the printer, you will see several 
pages with a single image on the upper left hand corner and nothing else printed 
on the rest of pages.  Finally, you will get the document you printed with the 
images missing.  

Kevin M. mentioned that this could be an iframe or a frame issue.  However, I 
did not see these tags, but did see a LAYER tag.  

This feature occurs on several popular Web sites so I nominate this for N6.5 
since it's common frustration with end users who have given feedback on this in 
the newsgroups.

Expected Results: In Communicator, you get only the pages that you printed :-)

Build Date/Platform: 2001010310 using NT
Nominating for nsbeta1 and changing milestone to mozilla 0.8.  Not sure if this 
is the correct thing to do so please make the necessary adjustments to get this 
fix in for N6.5

Also reassigning from dcone to rods based on a conversation with Kevin M.
Assignee: dcone → rods
Keywords: nsbeta1
Target Milestone: --- → mozilla0.8
Don, any updates on this bug?  
I tried this and see exactly what bijal says. However, we do not support layers 
anymore on 6.0. 
Hmmm...  If I can see the page in Navigator properly, I thought we supported 
layers.  Not sure why we can't just print what I am seeing.
Pls see the document http://sites.netscape.net/ekrockhome/standards.html
The paragraph for "What Nav4 Features Don't Netscape 6 and Other Mozilla- and 
Gecko-based Browsers Support?" mentions this. I dunno why the page prints 
incorrectly but renders fine 
This is a pagination issue.  The page is layed out in a table, and I think page 
breaks are being generated .. and it appears as if the images are getting there 
own page.  This is known issue.. reassigning to Karnaze.. he has a few bugs this 
is that same as.. probably a duplicate.
Assignee: rods → karnaze
I see this in Mac builds, too.
Printing pages at http://www.washingtonpost.com shows similar problem.
All/All
OS: Windows NT → All
Hardware: PC → All
I had the same problem on MapQuest (this was my query, but I don't think that
matters, but I don't want to waste ink testing..)
http://www.mapquest.com/cgi-bin/mqtrip?link=btwn%2Ftwn-ddir_na_basic_main&reset=reset&uid=u2hew0o9idlaiwkd%3A8510txlu7&tq_source=expr&ADDR_0=&CITY_0=christiansburg&STATE_0=va&ZIP_0=&CC_0=US&ADDR_1=&CITY_1=emory&STATE_1=va&ZIP_1=&CC_1=US&dir=Get+Directions
Except the banners that printed on the first two pages were not even on the site
(or had been dynamically replaced) the rest of the page printed fine after a
blank page and two banner image pages.
Moving to mozilla0.9.
Status: NEW → ASSIGNED
Target Milestone: mozilla0.8 → mozilla0.9
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay
*** Bug 69417 has been marked as a duplicate of this bug. ***
*** Bug 70508 has been marked as a duplicate of this bug. ***
I do not think this is a dupe of 24952.
This one involves  a table generated by Javascript.
The strange behavior is that Mozilla fires separate printing command for each
banner.
This is manifested if you set the printing layout to be different from default
in the printing dialog.
The first banner follows the temporary change, but other pages are printed using
default settings.
Blocks: 64841
Changing url from http://www.businessweek.com to http://www.washingtonpost.com. 
I don't see the problem on the original url or the other ones mentioned in the 
bug (except washingtonpost).
I can't even reproduce the problem on washingtonpost now, although I did see it 
happen once. Marking m1.0.
Keywords: qawanted
Target Milestone: mozilla0.9 → mozilla1.0
This page shows the behavior:
http://www.zdnet.com/pcmag/stories/trends/0,7607,2701390,00.html

The top banner and search section print on one page followed by the sidematter
and article text on a second.  In that the sidematter is now printed with the
text, this is an improvement.  The layout seems to be done with fairly
traditional table techniques, with the top part being its own table.
Recent fixes to printing seems to a fixed printing of www.businessweek.com and
www.washingtonpost.com. Tested using 2001041704 build on WINNT.

Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → WORKSFORME
verified in 4/20 build.
Status: RESOLVED → VERIFIED
I have found a page that shows this bug in 042308 build.
http://encarta.msn.com/find/print.asp?&pg=8&ti=06750000&sc=0&pt=1
If you print this page, the top banner gets printed in the first page and the
rest are printed in separate pages.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
This bug is absolutely not fixed.  I encourage you to try some of the links
provided by myself and others that show this.  To reiterate, this one:

http://www.zdnet.com/pcmag/stories/trends/0,7607,2701390,00.html

I think the issue for us is that the description and analysis of what's wrong is
so loose that maybe there are still several things wrong.  in any case, I have
tested several pages listed among the comments and most continue to fail.  I am
using 2001042304 on win2k.
http://encarta.msn.com/find/print.asp?&pg=8&ti=06750000&sc=0&pt=1

prints fine for me with 20001042304 build on WINNT.

http://www.zdnet.com/pcmag/stories/trends/0,7607,2701390,00.html

prints incorrectly. May be a block bug



 This prints fine to me... I was tring to minimise the testcase for other bugs 
with the similar summary.. www.washingtonpost.com prints fine...
Build Id # 2001082403
Platform: WIn2K
I just tried the Economist link and the zdnet link.  Economist prints ok
(20010824).  The zdnet link (which I think I submitted) doesn't have the same
layout as the original, and that may or may not play a role in why it prints ok
now.  There is on this page still a problem: the printing is *very* slow
(another bug I'd once reported).  Printer is an HP 8100 on a Netware network. 
The data light flashes for maybe three minutes before each page prints.
Frank what is the bug number for the printing slowly bug ?

I think we can mark this bug RESOLVED-WFM.
marking this bug RESOLVED-WORKSFORME. if anyone can provide a page
that demonstrates this problem consistently then REOPEN and provide
the page.
Status: REOPENED → RESOLVED
Closed: 23 years ago23 years ago
Resolution: --- → WORKSFORME
verified in 8/24 build.
Status: RESOLVED → VERIFIED
I believe it is bug 77383.  Most of the discussion where I described the
slowness was in some other bug (don't know which one) then someone said "change
the print delay" and then this new bug number appeared.
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.