Last Comment Bug 644559 - oi.com.br - Site homepage is blank in Firefox 4, as of 2009-12-02 nightly
: oi.com.br - Site homepage is blank in Firefox 4, as of 2009-12-02 nightly
Status: RESOLVED FIXED
[strict mode? tech evang?]
: qawanted, regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: general
:
Mentors:
http://www.oi.com.br
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-24 05:49 PDT by Victor da Silva
Modified: 2011-05-20 13:57 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Victor da Silva 2011-03-24 05:49:44 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 ImageShackToolbar/5.2.4 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16 ImageShackToolbar/5.2.4 ( .NET CLR 3.5.30729)

Porque o site da oi não abre no firefox 4 final ? 

Reproducible: Always
Comment 1 Ed Morley [:emorley] 2011-03-24 14:27:19 PDT
Using Google translate:
"Because the site does not open in firefox hi 4 final?"

The site in the URL field doesn't work using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110324 Firefox/4.2a1pre ID:20110324030442

And give the following errors in the error console:

Error: [Exception... "'JavaScript component does not have a method named: "handleEvent"' when calling method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "<unknown>"  data: no]

Error: google.ww is undefined
Source File: http://www.google.co.uk/extern_js/f/CgJlbhICdWsrMFo4ACwrMA44ACwrMDE4ACwrMBg4ACyAAjeQAjU/Z3caPPHSXfA.js
Line: 41

However, this site doesn't work in Chrome 11.0.696.16 dev either.
Comment 2 Ed Morley [:emorley] 2011-03-24 19:00:10 PDT
Using m-c...

Last good nightly: 2009-12-01 
First bad nightly: 2009-12-02

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57&tochange=a5e1b195ecf7

Using tm...
Last good nightly: 2009-11-19 
First bad nightly: 2009-11-20

Pushlog: http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=c84622414ed3&tochange=2ca2a236da89

-> Lots of strict mode changes in that range, but no script mode error in console?

Moving to Core::JS for now, at least until someone more knowledgeable can find the exact cause and bump to tech evang.
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-03-25 19:30:59 PDT
The site itself doesn't seem to have any strict mode stuff, but ga_redirect is strict-mode.... but that shouldn't break it, I'd think.

I also don't get the exceptions from comment 1.
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-05-20 12:47:15 PDT
The site works now, so I assume they fixed whatever it was....

Victor, is this still a problem?
Comment 5 Victor da Silva 2011-05-20 13:57:50 PDT
Thanks, the bug has been fixed.

Note You need to log in before you can comment on or make changes to this bug.