SSL info popup shows '... mozilla.org, which is run by (unknown)'

RESOLVED DUPLICATE of bug 429021

Status

()

RESOLVED DUPLICATE of bug 429021
8 years ago
8 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

unspecified
Firefox 4.0
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
For an example see http://sa.tk/9a0ac801.png

It says "You are connected to mozilla.org, which is run by (unknown)"

Looking at the certificate details I see:

http://sa.tk/7af78194.png

Organization (O): Mozilla Corporation
Organizational Unit (OU): Secure Web Server

Isnt the Organization supposed to be shown in the SSL info popup in place of (unknown) ?
(Reporter)

Comment 1

8 years ago
Created attachment 521534 [details]
Popup
(Reporter)

Comment 2

8 years ago
Created attachment 521536 [details]
Certificate Details

Comment 3

8 years ago
bug 444980 / bug 429021

The organization is only shown for EV certificates, because it can not be verified for the others.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429021
You need to log in before you can comment on or make changes to this bug.