Closed Bug 644708 Opened 11 years ago Closed 10 years ago

A still running mesage appears if I close and I open the browser again

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 407981

People

(Reporter: egjuli, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

I saw that this bug is already reported but it was evaluated as invalid and I don't know why. The thing is that when you're using Firefox and then you close it but you wanna open it again quickly, I mean that you click the exit button and instantly after that you click the firefox icon (mine is in the Quick Launch if it's relevant), a messages appears saying that firefox is still running but doesn't respond. Then you close that message and you tray again to open the browser and it works. This used to happen me with the newest versions of fx3 and now with fx4 it stills happen. 

Reproducible: Always

Steps to Reproduce:
1.Open fx
2.Close fx
3.Instantly try to open it again
Actual Results:  
The message saying fx is still running but doesn't respond appears.

Expected Results:  
Nothing just open fx.

I have the normal addons such as adblock plus, Download Helper, ref control, some dictionaries, weather forecast, and the "heaviest one" the Cooliris. I'm using XP x86.
Could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Severity: critical → major
Version: unspecified → Trunk
(In reply to comment #1)
> Could you see if the issue occurs if using Firefox in safe mode:
> http://support.mozilla.com/kb/Safe+Mode
> 
> How about with a new, empty testing profile? (Don't install any addons into it)
> http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile

Okay, I tried using Firefox in safe mode and is the same thing. I checked it out with the task manager and I can tell you that the problem is that when you close Firefox in the task manager appears like it's still running for about three or four seconds. If you close the browser and you wait those three seconds the process Firefox disappears from the task manager and you can open again the browser without the message appearing saying that Firefox is still running.
Reporter, please can you confirm whether this issue still occurs using Firefox 4.0.1 (http://www.mozilla.com/firefox/new/) or higher, in Firefox safe mode (http://support.mozilla.com/kb/Safe+Mode) and/or with a clean profile (http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile). Ideally, also check using the latest nightly: http://nightly.mozilla.org/

If this issue no longer occurs, please close as "Resolved Worksforme".

It it in fact still occurs, please provide as much extra information as possible, including what versions tried, whether safe mode/new profile tested etc. Thanks! :-)

(Template reply to inactive UNCO bugs)
First of all thanks for the response cause I was wondering what happened cause nobody was answering. I tried it again using safe mode and with a clean profile and it keeps happening. I'm running the latest not beta version, I mean the 4.0.1.

Thanks and I hope you can solve it cause it's very annoying.
Severity: major → critical
Priority: -- → P1
Thanks for the update.

It's normal for Firefox to take a second or two to close; so if you run it within that time-frame, you will get that message. Addons and/or an old/large profile will make this timeframe larger.

If you leave task manager open when quitting Firefox, what kind of delay are we talking about before the Firefox.exe process closes? What are your system specs? (CPU, ram, hard drive type/speed etc) How does the delay vary if you try a clean profile with no addons installed?
Severity: critical → normal
Priority: P1 → --
Reporter -> Any update? Please address the questions in comment 5?
Dupe of Bug 407981 .

@OP: Yes, it should close more quickly.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407981
You need to log in before you can comment on or make changes to this bug.