Closed Bug 644712 Opened 9 years ago Closed 7 years ago

Crash @ js::Bindings::lookup

Categories

(Core :: JavaScript Engine, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

It is a new crash signature that first appeared in 4.0b12.
It is #69 top crasher in 4.0 over the last 3 days.

Signature	js::Bindings::makeImmutable()
UUID	301f94e0-61e0-443f-93ad-161372110324
Time 	2011-03-24 01:11:17.938316
Uptime	150
Last Crash	152 seconds before submission
Install Age	3137 seconds (52.3 minutes) since version was first installed.
Product	Firefox
Version	4.0
Build ID	20110318052756
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 30 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address	0x8a
User Comments	Nach Speicherung im Windows live Messenger (neuer Kontakt) ist Firefox regelmäßig abgestürtzt. Jippi, welche Freude der Kontakt war aber jedesmal gespeichert. Na, welche Freude.
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 06c0, AdapterDriverVersion: 8.17.12.6099
D2D? D2D+
DWrite? DWrite+
D3D10 Layers? D3D10 Layers+

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js::Bindings::makeImmutable 	js/src/jsscript.cpp:285
1 	mozjs.dll 	JSScript::NewScriptFromCG 	js/src/jsscript.cpp:1490
2 	mozjs.dll 	js::Compiler::compileScript 	js/src/jsparse.cpp:1124
3 	mozjs.dll 	EvaluateUCScriptForPrincipalsCommon 	js/src/jsapi.cpp:5053
4 	mozjs.dll 	JS_EvaluateUCScriptForPrincipalsVersion 	js/src/jsapi.cpp:5075
5 	xul.dll 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1460

More reports at:
https://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&signature=js%3A%3ABindings%3A%3AmakeImmutable%28%29

4.0 correlations by module give:
71% (173/242) vs.   1% (3008/279318) kikin_4_0.dll
http://www.kikin.com/ is the location of the addon. Will try installing it to see if I can repro.
[@ js::Bindings::lookup(JSContext*, JSAtom*, unsigned int*) ] is another signature that is correlated to this addon/plugin.
Summary: Crash [@ js::Bindings::makeImmutable() ] mainly with kikin 4.0 → Crash [@ js::Bindings::makeImmutable() ] [@ js::Bindings::lookup(JSContext*, JSAtom*, unsigned int*) ] mainly with kikin 4.0
Blocks: 637304
Hello, I'm the developer of the Firefox extension at kikin. I'm looking for information that help me fix this problem. Since kikin is not in the crash call stack it is difficult for me to know what I'm doing wrong exactly. kikin works fine in Firefox 3.6 but I suspect I'm not doing something FF 4 requires. 

If me providing a description of what the extension is trying to do, or source code, would help in figuring out the problem please let me know. 

Any information would be appreciated. Thank you in advance.
Now #23 top crasher in 4.0 over the last 3 days.
Blocks: 646745
Crash Signature: [@ js::Bindings::makeImmutable() ] [@ js::Bindings::lookup(JSContext*, JSAtom*, unsigned int*) ]
* js::Bindings::makeImmutable():
There have been no crashes in versions above 6.0.2 for the last four weeks.

* js::Bindings::lookup(JSContext*, JSAtom*, unsigned int*):
There is not enough crash data to get correlations.
No longer blocks: 637304, 646745
Crash Signature: [@ js::Bindings::makeImmutable() ] [@ js::Bindings::lookup(JSContext*, JSAtom*, unsigned int*) ] → [@ js::Bindings::lookup(JSContext*, JSAtom*, unsigned int*) ]
Summary: Crash [@ js::Bindings::makeImmutable() ] [@ js::Bindings::lookup(JSContext*, JSAtom*, unsigned int*) ] mainly with kikin 4.0 → Crash @ js::Bindings::lookup
There have been no crashes for the last four weeks after 16.0.1.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.