Closed Bug 645015 Opened 9 years ago Closed 9 years ago

Files saved as PDF are identically named

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ioana.chiorean, Assigned: wesj)

Details

Attachments

(2 files)

Attached image same name
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.2a1pre)Gecko/20110325
Firefox/4.2a1pre Fennec /4.01a1pre
Device: Samsung Galaxy S Captivate
OS: Android 2.1 update 1

Steps to reproduce:
1. Go to planet.mozilla.org
2. Save page as PDF twice.

Actual result:
- the files are named identically(but when you want to delete one of them, it appears with the suffix -2 as it should be)


Expected result: 
- the files should have attached a suffix (-1, -2 etc)

Note: 
- please see the attached photo

Also the open and delete buttons, and progress bar appear only if a close the app and I restart it again. Is this a different bug or is intended?
Assignee: nobody → wjohnston
Attached patch PatchSplinter Review
Use the created filename when adding to downloads.sqlite
Attachment #522381 - Flags: review?(mark.finkle)
Comment on attachment 522381 [details] [diff] [review]
Patch

Does this result in the same behavior as desktop Firefox?

What kind of browser-chrome tests can we start adding for downloads?
Attachment #522381 - Flags: review?(mark.finkle) → review+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified on build: Mozilla /5.0 (Android;Linux armv7l;rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre Fennec /4.1a1pre 
Device: HTC Desire (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.