Closed Bug 645037 Opened 10 years ago Closed 10 years ago

Running Venkman javascript debugger on firefox 4.0 gives error window

Categories

(Other Applications Graveyard :: Venkman JS Debugger, defect)

x86_64
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 614557

People

(Reporter: mauro.viarizzo, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

I have installed venkman 0.9.88.1, but when I try to run it on Firefox 4.0 production I receive the following error message on an error window: 

An exception occurred while initializing, please file a bug.
[Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [jsdIDebuggerService.on]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: chrome://venkman/content/venkman-debugger.js :: initDebugger :: line 131"  data: no]

Note: No other extension installed, plain Firefox 4.0 production.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox 4.0 - fresh installation
2. Install Javascript Debugger 0.9.88.1 extension
3. Start Javascript Debugger
Actual Results:  
A window with error message appears :
An exception occurred while initializing, please file a bug.
[Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [jsdIDebuggerService.on]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: chrome://venkman/content/venkman-debugger.js :: initDebugger :: line 131"  data: no]

After that, the debugger opens but it does not do any operation. 

Expected Results:  
No errors

Firefox 4.0 fresh installation: No themes, no other Addon except for Java Quick Starter 1.0.
Component: Extension Compatibility → Venkman JS Debugger
Product: Firefox → Other Applications
QA Contact: extension.compatibility → venkman
Version: unspecified → Trunk
This has been fixed on trunk, but not released yet. The maxVersions for Venkman
0.9.88.1 on AMO are wrong; that version doesn't support FF 4.0.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614557
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.