Mac OS X 10.5 cannot launch Firefox 4 with command line argument -P

VERIFIED DUPLICATE of bug 602049

Status

()

--
critical
VERIFIED DUPLICATE of bug 602049
8 years ago
8 years ago

People

(Reporter: jloveridge, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20110513][DUPEME])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.204 Safari/534.16
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0) Gecko/20100101 Firefox/4.0

I am no longer able to launch Firefox 4 using a specific profile on Leopard. Snow Leopard is unaffected regardless of launching the application in 32-bit or 64-bit mode. This is 100% reproducible via the command line.


Reproducible: Always

Steps to Reproduce:
1. Open a Terminal prompt
2. Execute the following command: /Applications/Firefox.app/Contents/MacOS/firefox-bin -P profilename

Actual Results:  
Application crashes.

Console output is:
dyld: unknown required load command 0x80000022
Trace/BPT trap

Mac OS crash reporter provides the following:

Process:         firefox-bin [581]
Path:            /Applications/Firefox.app/Contents/MacOS/firefox-bin
Identifier:      firefox-bin
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  bash [161]

Interval Since Last Report:          39 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  0 sec
Per-App Crashes Since Last Report:   1

Date/Time:       2011-03-25 11:25:46.975 -0600
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  E920EAAC-8FF2-4366-B36E-4A2D5F611D4D

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  unknown required load command 0x80000022


Expected Results:  
Launch Firefox using the specified profile

Comment 1

8 years ago
Confirmed:

$ firefox.app/Contents/MacOS/firefox -P Firefox_v40 -no-remote
$ dyld: unknown required load command 0x80000022
$ Trace/BPT trap

("Firefox_v40" is my correct profile nickname.)  Is it possible this is no longer the way to start Firefox from the OS X command line?  (On FF3.6 I used to have to copy run-mozilla.sh from FF3.5, but FF4.0 appears to have one, although it has a lot of diff.)
(Reporter)

Comment 2

8 years ago
Ken,

The only problem I see in what you are trying to do is that you didn't specify firefox-bin. I have had mixed success trying to pass command line arguments to the firefox binary directly and have always used firefox-bin. Using the exact same command line works for me in OS X 10.6.x. Additionally on 10.6 I am able to launch in either 32-bit or 64-bit mode when using the command line and it honors the command line variables as expected. As an example: to launch in i386 mode on Snow Leopard using your profile you should be able to issue the following command and have it succeed:

$ arch -arch i386 /Applications/firefox.app/Contents/MacOS/firefox-bin -P Firefox_v40 -no-remote
(Reporter)

Comment 3

8 years ago
Looks like the real source of the issue is that when running on Leopard it tries to execute it as an x86-64 binary instead of i386 when run from the command line. I am able to launch from the command line on 10.5.8 when using:

$ arch -arch i386 /Applications/firefox.app/Contents/MacOS/firefox-bin -P profilename

If I do not manually specify the architecture it fails.

Comment 4

8 years ago
"firefox" with "arch" failed;
"firefox-bin" without "arch" failed;
"firefox-bin" with "arch -arch i386" succeeded;
"firefox-bin" with "arch -arch x86_64" failed.

But my understanding is that "firefox" sans "-bin" sans "arch" is supposed to work, did work in all versions prior to 4.0 (after restoring run-mozilla.sh to 3.6), and is supposed to be the "proper" way.  "firefox" is just a shell script that does some environment stuff and runs run-mozilla.sh which does some more environment stuff and runs firefox-bin; if that environment stuff is neither necessary nor proper, and if the scripts don't work anyway, then why are they there?

Also, my Core2Duo MacBook with 10.5.8 is running three 64-bit processes right now:  iStatLocal, Wraparound, and SMARTReporter.  Shouldn't it be able to run 64-bit Firefox too?

Comment 5

8 years ago
Bumping to Widget: Cocoa, since Josh et al might have some ideas here.
Component: General → Widget: Cocoa
Product: Firefox → Core
QA Contact: general → cocoa
Version: unspecified → Trunk
I have the feeling this is a dupe. Ted, I assume you can help out.
Whiteboard: [bugday-20110513][DUPEME]
Yes. We decided a while ago not to support this. If you want to run the binary from the commandline on 10.5, you'll have to use "arch -arch i386". Everything works fine running the bundle from Finder, which is the use case we care about.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 602049
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.