maxwidth on textarea makes enclosing table cell too small for textarea.

RESOLVED DUPLICATE of bug 102440

Status

()

defect
RESOLVED DUPLICATE of bug 102440
8 years ago
8 years ago

People

(Reporter: glen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

The following html produces a table in which the second textarea extends outside of its enclosing table cell.
-----
<html>
<table border='1'>
<tr>
<td>
AAA
</td>
<td>
<textarea rows='4'>
Here is a long line, and the table cell expands to hold it.
</textarea>
</td>
<td>
<textarea maxWidth='80'>
This textarea extends right out of the table cell.
</textarea>
</td>
</tr>
</table>
maxwidth seems not to control the textarea, but the tabel cell containing it.
</html>


Reproducible: Always

Steps to Reproduce:
1.Load above html or use URL above.
2.
3.
Actual Results:  
Second textarea extends to the right beyond the end of the enclosing table cell.

Expected Results:  
Table cell should expand to enclose textarea.
Reporter

Updated

8 years ago
Version: unspecified → 4.0 Branch
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: 4.0 Branch → Trunk
This is basically the same issue as bug 102440.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102440
You need to log in before you can comment on or make changes to this bug.