URL Tooltip extremely annoying - either restore statusbar or add option to turn it off!

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
8 years ago
8 months ago

People

(Reporter: klaus.kusche, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20110401])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110326 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20110326 Firefox/4.0

The URL tooltip which shows up in the lower left corner when hovering or
clicking links ist extremely annoying and visually distracing:
It appears, disappears, changes size, ...

It is impossible to do concentrated work in firefox for longer periods
because this nasty little beast is flashing and flickering at me all the time,
catching my attention!
(especially on web pages with dark background!)

Please include an option to restore the old status bar,
it was by far less distracing and less visually annoying!
(or at least include an option to disable the tooltip
or make it appear only after a one-second delay).



Reproducible: Always

Steps to Reproduce:
Move your mouse over a link or click it.

Comment 1

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

Klaus, thanks for reporting this. Toolips are meant to be displayed by default but you can easily disable them by:
 1. Access about:config
 2. Look for browser.chrome.toolbar_tips and disable it
 3. Restart Firefox and tooltips should disappear.

Hope this helps. Setting resolution to Resolved Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
Your solution is not related to the problem at all.

I'm not talking about the toolbar tips.
I'm talking about the tooltip-like popup in the lower left corner
which replaced the status bar and shows
- the link URL when you move the mouse over a link
- the connection status when firefox loads a page
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Blocks: 541656
OS: Linux → All
Hardware: x86_64 → All

Comment 3

8 years ago
Now I understand what you were trying to explain. Unfortunately I don't know of any way of getting rid of that toolbar/status bar. 

Maybe someone else has any idea?

Comment 4

8 years ago
Use "statu 4 ever" addon.
(Reporter)

Comment 5

8 years ago
That addon solves the problem.

Should I rely on the addon or is there a chance 
to get a firefox option which allows to switch to the oldstyle status bar?

Comment 6

8 years ago
(In reply to comment #4)
> Use "statu 4 ever" addon.

FWIW, exact name: "Status-4-Evar".
Moving this to enhancements
Severity: normal → enhancement
Whiteboard: [bugday-20110401]

Comment 9

7 years ago
I don't want to have to install yet another memory-hungry add-on just do something which Firefox SHOULD and previously DID do natively!

The status location bar tooltip pop-up balloon or whatever it's being called now should have the following options:

1) NO TIME-DELAY IN DISPLAY.  For years and years I've had the occasion to need to quickly verify that a list of links were generated correctly or compare differences by simply hovering the mouse over them.  The stupid display-delay not only slows down my productivity significantly, but it also sometimes displays the wrong link because all the time-delays are trying to play catch-up.

2) Lock it to the bottom-LEFT corner of the screen so that I don't have to keep wondering where the hell the link display is.  After 15+ years of using web browsers, I've come to subconsciously expect it to ALWAYS appear in the bottom-left corner, so it's infuriatingly annoying when it's unexpectedly (often unpredictably) NOT where I expect to see it AT A GLANCE.  (And what @#%*-for-brains imbecile really thought right-aligning a diversely varying string was a good idea?  Numbers, sometimes yes, but long URLs, NEVER!)

3) Lock it to a static never-hides bar OUTSIDE of the document window, maybe on that add-on bar for which I otherwise still haven't found a reason why I should keep it.  It's incredibly annoying when I can't see some content which is hidden behind the location balloon or the balloon suddenly shifts to a different position because the mouse is pointed where it wants to be.

It's features like this which should never be taken out, but rather be made optional, and even then they should be left "on" by default since loyal users EXPECT them to be there when upgrading and only the developers who bungled things up know how to unbungle them.
(In reply to Klaus Kusche from comment #5)
> Should I rely on the addon or is there a chance 
> to get a firefox option which allows to switch to the oldstyle status bar?

The former.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → WONTFIX

Comment 11

6 years ago
Whenever I'm watching a video on Netflix, the url 'popup' stays on continually in the lower corner.  It will move to the other corner if I click on it, but I cannot get rid of it!  I had to install Status-4-Evar to get it to not block the movie. It would be nice if the firefox crew would listen to their users. I realize they are doing a lot of hard work, but they seem to be moving away from what firefox was known for - stability and control for the user.  I understand that the latest craze in developement is scrum and agile development, but it's becoming fragile development, and it's only emphasizing stability and control for the developer.

Comment 12

6 years ago
By the way - I really like the Status: RESOLVED WONTFIX - ha! At least it's an admission that it's broken!

Comment 13

6 years ago
I still use version 12 at work on my laptop.  Cannot get any new version to work right - no idea why...

Updated

8 months ago
Duplicate of this bug: 1461163
Duplicate of this bug: 633720
(Reporter)

Comment 16

8 months ago
The bug was closed as "wontfix", because at that time,
multiple addons existed to turn off that flickering annoyance
and add a traditional status bar with all the URL and network information instead.
Hence, there was no need to fix that in firefox itself.

However, all these addons are gone with firefox 57,
and there is no way to fix that by external means any longer,
and to restore the traditional status bar.

So the closing reason is no longer valid,
and this needs to be fixed in firefox itself now.

See 1461163: The problem still exists in firefox 57+,
and it is only possible to suppress the information
(which is no option since URL targets are security relevant information,
and the connection status is useful for network problems),
but it is not possible to display URL and the connection information
in a statically displayed, fixed-location and non-flickering status bar.

Hence, this is a regression which needs to be fixed.

It's even a formal requirement:
Everything which blinks or flickers with less than 0.3 sec on-time or off-time
is violating germany's official requirements for gui design "BITV"
(to protect people with epileptic disorder).
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

8 months ago
Sorry, I've set it to "verified" instead of "unconfirmed" by accident,
some maintainer please reset it to "unconfirmed" or "confirmed"!
We're not going to bring the old status bar back. For any accessibility concerns with the status panel, please file new bugs specifically on those.
(Reporter)

Comment 19

8 months ago
Why not? Any reasons for that?

The status bar is by far superior to the current solution:
- The old statusbar was significantly less annoying and distracing.
- The old statusbar provided more information.
- In my firefox, the old statusbar (as provided by Status4Evar and ClassicThemeRestorer)
  contains more than 10 plugin icons and the zoom level control (- % +).
  For all the icons I have down there in the status bar, the url/menu bar would be by far too short ...

Screen real estate was the only argument against a status bar 7 years ago
(and the reason why most browsers dropped their status bar at that time), 
but isn't any longer due to the increasing display sizes 
(for me: 28" in the office and 30" at home).
There is plenty space for a permanent status bar now...

So dropping the status bar is a regression,
there are no reasons for replacing it with something worse and dropping some of its features
and many reasons for keeping it (at least as a configurable option).

The status bar is one of 4 or 5 reasons why I switched to Firefox 52 LTS
(after happily using up-to-date or even beta Firefox versions for many years)
and will switch to some pre-57-Firefox clone or a completely different browser
in case the current version of Firefox isn't fixed until 52 LTS support ends.
You need to log in before you can comment on or make changes to this bug.