Closed Bug 645374 Opened 10 years ago Closed 10 years ago

JavaScript debugger raises exception window

Categories

(DevTools :: General, defect)

x86_64
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 614557

People

(Reporter: shri7287, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Raises an exception window everytime I try to open the debugger from firefox. But ultimately the debugger window does come up after I close the exception window.

Reproducible: Always

Steps to Reproduce:
Steps to reproduce:
1. Open the JavaScript debugger in firefox
2. It alerts a window as shown below:
An exception occurred while initializing, please file a bug.
[Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [jsdIDebuggerService.on]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: chrome://venkman/content/venkman-debugger.js :: initDebugger :: line 131"  data: no]

3. The debugger then opens up
Actual Results:  
Exceptions take place

Expected Results:  
Debugger has to open directly without any intermediate exception windows

Irrespective of any themes or any other default configuration this exception arises
Duplicate of bug 645053, if I'm not mistaken.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645053
(In reply to comment #1)
> Duplicate of bug 645053, if I'm not mistaken.

Yes, Thanks for pointing it out!
Duplicate of bug: 614557
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.