Closed Bug 645385 Opened 11 years ago Closed 11 years ago

setTimeout send ghost param

Categories

(Core :: JavaScript Engine, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 394769

People

(Reporter: ckkoshi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.14 Safari/534.24
Build Identifier: 4.0

Just try a setTimeout(alert,5);
alert will return a number value, but no param are expected here

W3C say "This method calls the function once after a specified number of milliseconds elapses, until canceled by a call to clearTimeout. The methods returns a timerID which may be used in a subsequent call to clearTimeout to cancel the interval."
http://www.w3.org/TR/Window/

Reproducible: Always
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394769
You need to log in before you can comment on or make changes to this bug.