Scripts override default keyboard shortcuts (arrow keys), killing usability

RESOLVED DUPLICATE of bug 380637

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 380637
7 years ago
7 years ago

People

(Reporter: Andrew, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: 

A side effect of Javascript becoming more ubiquitous, every site tries to be different or things they can do things "better". Various sites override Firefox shortcut keys, from ctrl-xx to the arrow keys themselves, making the sites practically unnavigatable without a mouse, removing consistency in the browser, and generally making it a nightmare to use.

Examples:
http://api.jquery.com -- has a list of function calls. I don't care, I search for show() using firefox search. I read the short description and want to see what's below it, hitting the down arrow a few times, which throws me back to the A's, using their own proprietary scrolling mechanism. Ugh. Google instant uses the same mechanism and prevents me from scrolling to the bottom of the page.
http://facebook.com -- the image viewer intersects the left/right arrow keys. If I want to scroll right to see the rest of the image or details about the image, it instead takes me to a different image
http://slashdot.org / jQuery in general: when you use a jQuery dialog, it intercepts the escape key to close the window instead of stopping the page from loading further data.

At the least, I would like an option added to the Advanced Javascript Options, "Allow script to: intercept keyboard events". Less cumbersome, "Allow scripts to: override default shortcut keys". One of these two options should really be implemented to keep the web usable for those that don't rely solely on a mouse.

See comments from others wanting to prevent this: http://superuser.com/questions/168087/how-to-forbid-keyboard-shortcut-stealing-by-websites-in-firefox


Reproducible: Always

Steps to Reproduce:
1. Go to http://api.jquery.com
2. Change focus from the search textbox to the page
3. Use the up/down arrow keys.

Actual Results:  
The site goes through a list of function calls

Expected Results:  
The site would scroll, one line at a time, from the top to the bottom.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 380637
You need to log in before you can comment on or make changes to this bug.