Closed Bug 645478 Opened 12 years ago Closed 12 years ago

App tabs are lost forever if browser window closed and then Firefox quit.

Categories

(Firefox :: Session Restore, defect)

All
macOS
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 625016

People

(Reporter: julespayne, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

After I closed all Firefox's windows and then quit Firefox with no Firefox windows open, the next time I opened Firefox all my app tabs were lost. This is serious because it is common on a Mac to leave the application running in the background with no windows open even if you are not using it, and it becomes the default method of running an application on Lion which has no 'running app' indicators in the dock.

Reproducible: Always

Steps to Reproduce:
1. Set up some app tabs.
2. Close all Firefox windows.
3. Quit Firefox.
4. Reopen Firefox.
Actual Results:  
All of your saved app tabs are lost permanently every time.

Expected Results:  
App tabs should be saved permanently.

This is not caused by a crash, no themes were applied and still occurs if all plugins and extensions are disabled.
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587400
its more a duplicate of bug 625016
Makes sense.
Duplicate of bug: 625016
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.