Closed Bug 645516 Opened 10 years ago Closed 9 years ago

get addons lags in addons manager

Categories

(Toolkit :: Add-ons Manager, defect)

7 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 623615

People

(Reporter: rakshithbekal, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110327 Firefox/4.2a1pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110327 Firefox/4.2a1pre

scrolling and pageresponse is slow in the "get addons" page in the addons manager  on my computer

Reproducible: Always




enabled smooth scrolling and all hw acceleration and my driver is x3100.I know its blacklisted but still Please check with your pc If it happens on your browser.
Works for me on Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre

Also, could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Can you please try again with firefox 4 final? It shouldn't happen anymore.
yeah I guess you can block this bug because I realized it varies based on computer hardware as I enabled all kinds of hardware acceleration on x3100 drivers. I just ask you to make D2D 10 fully compatible with x3100
thanks
Closing based on comment 3
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 4.0 Branch
I think this is still a problem (using 7.0 beta). Doing most things in 'Get Add-ons' is painfully slow such that I try to avoid it. I am using an older computer (Window XP SP4), but most everything else in firefox works pretty quickly compared to the clipped cpu spikes I get here.

Slow scrolling: I noticed similar comments in the related Bug 623615 which talks about slow scrolling in the Addons Manager in general: Bug 623615 Comment 110

Just doing circular motions with the mouse in most areas of the window causes cpu spikes: Bug 623615 Comment 15, Bug 623615 Comment 38, Bug 623615 Comment 112

Get Add-ons Page loads very slowly: Bug 623615 Comment 102
Can you reproduce in safe mode or a new profile?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
I tested it in both safe mode and in a new profile on the current ff7.0 beta. This is not new with ff7, but I think has been around since the new addons manager first came out.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: 4.0 Branch → 7 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623615
You need to log in before you can comment on or make changes to this bug.