Closed Bug 645629 Opened 9 years ago Closed 9 years ago

TI+JM: Assertion failure: ((size_t)atom & 0x7) == 0, at ../jsatom.h:73

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: jandem, Assigned: jandem)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

--
o1 = {};
o1 = 2;
function f(o) {
    o.__defineGetter__('valueOf', o6);
}
new f(o1);
f(o1);
--
$ ./js -a -n -m test.js
Assertion failure: ((size_t)atom & 0x7) == 0, at ../jsatom.h:73
Attached patch PatchSplinter Review
We did not always pass the atom pointer to stubs::CallProp. This could either crash or assert, depending on the value previously in Registers::ArgReg1.
Assignee: general → jandemooij
Status: NEW → ASSIGNED
Attachment #522620 - Flags: review?(bhackett1024)
Attachment #522620 - Flags: review?(bhackett1024) → review+
http://hg.mozilla.org/projects/jaegermonkey/rev/3b5b4dfda144
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 645991
You need to log in before you can comment on or make changes to this bug.