text align justifying paragraph in right to left direction languages

RESOLVED DUPLICATE of bug 185600

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 185600
7 years ago
7 years ago

People

(Reporter: Farzad, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

hi - Firefox team

(1)introduction----------------------------
before every thing excuse me for bad English,
congratulation for Firefox 4 and i use it for all time :-)
I'm a Persian user (like Arabic users - right to left)
i was see a viewing problem on Firefox that the IE haven't this problem.
i try to explain it to you:
(2)Description------------------------------
in you language (English) the characters of a word are separate from together and left to right;
but in my Persian language (like Arabic) the characters of a word are sticked together for example: ( سلام ) 
now: in English when you want apply text align justifying in a paragraph you make distance between all words in paragraph and you cant make distance between characters in every word and it may not be pretty, for example: "With dreams of world friendship" like:
   |||||With   dreams     of    world   friendship|||||
but in Persian language (like Arabic) we can apply distance between characters in all of the words  with dashes, for example: "با آرزوی دوستی همه دنیا" and:
   |||||بــا  آرزوی  دوسـتی  هـمـه  دنـیــا|||||
And it is much better!
and in IE this problem is solved
and i do not want you to be less than IE :-)
thank you for your attention.
Waiting for your answer
Farzad
bye


Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 522313 [details]
i sent the photo of different displaying in IE and FireFox

i sent the photo of different displaying in IE and FireFox

Comment 2

7 years ago
Looks like an old bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 185600
You need to log in before you can comment on or make changes to this bug.