Closed Bug 645695 Opened 11 years ago Closed 8 years ago

Fix offline tests to not use enablePrivilege

Categories

(Core :: Networking: Cache, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 871323

People

(Reporter: ted, Unassigned)

References

()

Details

The DOM offline tests all include offlineTests.js, which makes heavy use of XPCOM. That's going to need to be fixed for our "remove enablePrivilege" effort. As I see it, there are two options:
1) Rewrite the tests, factor the XPCOM bits out into simple APIs that can be added to SpecialPowers. I have no idea if this is feasible.
2) Move all the tests to mochitest-chrome, have a chrome sub-harness that does the XPCOM bits and loads content pages as needed to test content stuff.

I don't really care either way, but this is going to need help from the test authors.
Bug 871323 is basically the same. I made an effort, which failed, but bug 87132, comment 9 has a good explanation on what needs to be done.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871323
No longer blocks: 462483
You need to log in before you can comment on or make changes to this bug.