Last Comment Bug 645804 - Reset caps lock and alternate key setting when switching between input elements
: Reset caps lock and alternate key setting when switching between input elements
Status: RESOLVED FIXED
[hkb]
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 647338
  Show dependency treegraph
 
Reported: 2011-03-28 12:45 PDT by Kevin Brosnan [:kbrosnan]
Modified: 2011-10-21 11:17 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Kevin Brosnan [:kbrosnan] 2011-03-28 12:45:43 PDT
Native Android apps reset the caps lock (double press of shift key on hkb) and alternate key (double press of the alt key on hkb) when switching between input elements.

1. open http://google.com
2. press alt or shift twice on the hkb
3. type a couple characters in the Google search
4. press the address bar and type

results: shifted or alt characters typed in the address bar
expected: lowercase text

This should also be the same between form elements.
Comment 1 Alex Pakhotin (:alexp) 2011-10-21 11:17:22 PDT
Seems to be already fixed.

Note You need to log in before you can comment on or make changes to this bug.