Canvas invalidation broken

VERIFIED FIXED

Status

()

Core
Graphics
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: cpearce, Assigned: roc)

Tracking

({testcase})

Trunk
x86_64
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 522628 [details]
Testcase - should show smoothly incrementing frame number.

See attached testcase. I'm updating a frame counter once per frame at 30 fps in a canvas, and it isn't updating 30 once for every draw operation; sometimes my counter stops incrementing. I'm guessing we're not invalidating on every draw operation?

This is a regression since Firefox 4 shipped.

Bug exists in:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110328 Firefox/4.2a1pre

Bug doesn't exist in Firefox 4:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
I'd guess this was caused by bug 622072.
Assignee: nobody → roc
It's the "canvas.width = canvas.width;" reset in there that causes the problem...
Keywords: testcase
Fixed by backout.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 4

7 years ago
Verified with Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.