Xulrunner-2.0 fails to compile when alsa is not installed

VERIFIED DUPLICATE of bug 503691

Status

()

VERIFIED DUPLICATE of bug 503691
8 years ago
8 years ago

People

(Reporter: musv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (X11; Linux x86_64; U; de) Presto/2.8.119 Version/11.10
Build Identifier: xulrunner-2.0

When checking the config, Xulrunner fails:

checking for alsa... Package alsa was not found in the pkg-config search path.
Perhaps you should add the directory containing `alsa.pc'
to the PKG_CONFIG_PATH environment variable
No package 'alsa' found
configure: error: Need alsa for Ogg, Wave or WebM decoding on Linux.  Disable
with --disable-ogg --disable-wave --disable-webm.  (On Ubuntu, you might try
installing the package libasound2-dev.)

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/net-libs/xulrunner-2.0/work/mozilla-2.0/config.log
 * ERROR: net-libs/xulrunner-2.0 failed (configure phase):
 *   econf failed


The config check is correct. Alsa is not installed. Xulrunner should not have
alsa as an hard coded dependency in order to be able to use alternative sound
architectures e.g. OSS4.

Reproducible: Always




System config:
System: Gentoo AMD64
Kernel: 2.6.37 (Gentoo-Sources)
Soundsystem: OSS4
(Reporter)

Comment 1

8 years ago
Created attachment 522641 [details]
build.log
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503691
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.