Firefox won't remember the password on listen.grooveshark.com

RESOLVED DUPLICATE of bug 355063

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 355063
7 years ago
3 years ago

People

(Reporter: Kevin Bodor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

It used to work before, but recently, I don't know why, after updating to the latest Firefox 4 (and after all my bookmarks and passwords were deleted - my own fault -), when I went to listen.grooveshark.com and typed in my account and password. At first, I couldn't see the box where it should have said Remember Password, and after it finally showed, it wouldn't work. I opened the login window and nothing was completed.

Reproducible: Always

Steps to Reproduce:
1. go on http://listen.grooveshark.com/#/
2. open the login window
3. type the account name and password
4. click remember password (if it shows)
5. logout
6. open the login window again
Actual Results:  
The account name and password weren't automatically completed.

Expected Results:  
My account name and password were supposed to be already written in the boxes.

If it's of any help or relevance, I do have to state that I'm using the portable version of Firefox 4 final (from http://portableapps.com/).

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110328 Firefox/4.2a1pre 

Able to reproduce in firefox 3.6.16 also.
Component: Account Manager → Password Manager
Product: Firefox → Toolkit
QA Contact: account.manager → password.manager
Chances are with grooveshark being a very JS heavy app, that the form is script generated (which we don't detect - bug 355063) and is doing it's own form submission with ajax. The first part is possible to fix, the second part not so much.
Depends on: 355063
This is working for me now. It was likely fixed by bug 355063 and possibly changes on Grooveshark's part to use a form submission.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355063
You need to log in before you can comment on or make changes to this bug.