Add new RSS feed to thunderbird from the command line

RESOLVED WORKSFORME

Status

MailNews Core
Feed Reader
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Sean Dague, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.204 Safari/534.16
Build Identifier: Thunderbird 3.1.8

It is documented that you can add a new RSS feed to thunderbird from the command line with the following syntax:

 /usr/bin/thunderbird -mail feed:$url

However this hasn't worked on any of the 3.x builds I've tried.  Is this feature still available, and if not can some way to do this be put back in to the source?

Reproducible: Always
Component: General → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader

Comment 1

6 years ago
thunderbird.exe feed:$url works for me in Tb10 and likely earlier.  if that doesn't work in 3.1, there's one word: upgrade.

if indeed the doc is wrong, where?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

6 years ago
I'm on TB 10 now, and this still doesn't do anything under Linux. Can you provide an example $url that this works for, and what you see happen when you run that command from the command line.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

6 years ago
C:\Programs\Mozilla\Thunderbird>thunderbird.exe feed:http://addons.mozilla.org/en-US/firefox/extensions/format:rss?sort=featured

will subscribe the feed to an open Tb, create a folder (if not subscribed in the first feed account found), download feeds, and select the folder.

C:\Programs\Mozilla\Thunderbird>thunderbird.exe -no-remote -P test feed:http://addons.mozilla.org/en-US/firefox/extensions/format:rss?sort=featured

will start (must be closed, if a non-remote profile is open and you wish to open another profile) Tb with the profile, and repeat above.

now, this is win7.  i very vaguely recall -no-remote being implemented for some specific linux arg passing issues long ago, so that may or may not be a difference.

Comment 4

6 years ago
FWIW, works fine on linux for me. Tested in tb10.
(Reporter)

Comment 5

6 years ago
After deleting my entire RSS tree (about 100 feed), and reimporting them, this now works. It didn't work at all previously. But at least it's working now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.