Closed Bug 646135 Opened 9 years ago Closed 6 years ago

skype.com - It's impossible to create a Skype account with Firefox 4.0

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sfrti, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

i don't know more

Reproducible: Always

Steps to Reproduce:
1.enter a skype-name hit "?" for reaction, you will seen none
2.fill registration completed and go on confirm
3.you will landing back on this page with clear fields for Registration
Actual Results:  
previous Versions of Firefox haven't this problem
IE 8 has this problem not too
Version: unspecified → 4.0 Branch
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110329 Firefox/4.2a1pre ID:20110329030437

STR...
1) Go to https://login.skype.com/intl/en/account/signup-form
2) Scroll down to username field
3) Enter foo
4) Press question mark to the right of the field

Expected:
- Helper text popup

Actual:
- No popup

mc...
Last good nightly: 2009-12-01 
First bad nightly: 2009-12-02
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57&tochange=a5e1b195ecf7

tm...
Last good nightly: 2009-11-19 
First bad nightly: 2009-11-20
Pushlog: http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=c84622414ed3&tochange=2ca2a236da89

-> Lot of strict mode changes
-> Likely TE, but marking blocking bug 514585 for investigation by someone else who can figure out what's happening.

Reporter, this problem is likely something Skype need to fix (in which case it will get moved to the tech evangelism section), but someone else will follow up shortly. Either way, thanks for the bug report :-)
Assignee: nobody → general
Blocks: 514585
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → general
Summary: its impossible to create a Skype account with Firefox 4.0 → skype.com - It's impossible to create a Skype account with Firefox 4.0
Whiteboard: [Likely TE, but please confirm]
Version: 4.0 Branch → Trunk
Jim, Ed says's it's likely TE, and it looks like there were a bunch of ES lang changes by you in that regression range. Would you mind checking it out?
Okay.
This is likely relevant:

Error: assignment to undeclared variable _formBubbles
Source File: https://static2.skype.com/i/js/wbr-complete.js
Line: 3354

They have a var on _createBubble, but not on _formBubbles.  Oh, and it looks like they're using http://craigsworks.com/projects/qtip/ but comparing their code (which claims to be version 1.0.0-rc3 of the above) to the 1.0.0-rc3 I just downloaded, they have added this bit right after the license comment:

"use strict"; // Enable ECMAScript "strict" operation for this function. See more: http://ejohn.org/blog/ecmascript-5-strict-mode-json-and-more/
/*jslint browser: true, forin: true, onevar: true, undef: true, nomen: true, eqeqeq: true, bitwise: true, regexp: true, strict: true, newcap: true, immed: true, maxerr: 300 */
/*global window: false, jQuery: false */

Hence fail.
Assignee: general → english-us
Component: JavaScript Engine → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Whiteboard: [Likely TE, but please confirm]
Version: Trunk → unspecified
Yes, that looks like it. The changeset that broke it is probably this one:

Bug 514560: Forbid assignments to undeclared variables in strict mode code. r=jorendorff
http://hg.mozilla.org/tracemonkey/rev/595f6db1b7b3

How do we hand this off to TE?
(In reply to comment #5)

> How do we hand this off to TE?

bz already did. ;)

Someone just needs to contact Skype and explain the problem. Feel free to point them here if they need more help.
This is working for me with Firefox 32.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.