Last Comment Bug 646263 - TI: Incorrect results with compiled CPython
: TI: Incorrect results with compiled CPython
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: x86 Linux
: -- normal (vote)
: ---
Assigned To: general
:
Mentors:
Depends on:
Blocks: infer-regress
  Show dependency treegraph
 
Reported: 2011-03-29 16:28 PDT by Alon Zakai (:azakai)
Modified: 2011-04-20 13:15 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
unoptimized python (1.38 MB, application/octet-stream)
2011-03-29 16:29 PDT, Alon Zakai (:azakai)
no flags Details
optimized python (1.80 MB, application/octet-stream)
2011-03-29 16:29 PDT, Alon Zakai (:azakai)
no flags Details

Description Alon Zakai (:azakai) 2011-03-29 16:28:06 PDT
The attachment is CPython compiled to JavaScript (two versions - one with optimizations, one without). Running it in jaegermonkey with -m gives incorrect errors, while running without -m works fine.

This is similar and perhaps related to bug 643805.

Btw, after the previous TI/compiled code bugs were fixed, currently all 528 of the emscripten automatic tests pass except for FreeType (bug 643805) and this one. Very nice!
Comment 1 Alon Zakai (:azakai) 2011-03-29 16:29:16 PDT
Created attachment 522850 [details]
unoptimized python
Comment 2 Alon Zakai (:azakai) 2011-03-29 16:29:45 PDT
Created attachment 522851 [details]
optimized python
Comment 3 Jan de Mooij [:jandem] 2011-03-30 06:37:06 PDT
(In reply to comment #0)
> Btw, after the previous TI/compiled code bugs were fixed, currently all 528 of
> the emscripten automatic tests pass except for FreeType (bug 643805) and this
> one. Very nice!

Nice! Is this also with -n? (-n enables TI, so |-m -n| or |-m -n -a| are the most interesting options).

I will reduce this one after bug 643805 is fixed. 500,000 lines will take some time ;)
Comment 4 Alon Zakai (:azakai) 2011-03-30 10:25:01 PDT
(In reply to comment #3)
> Is this also with -n? (-n enables TI, so |-m -n| or |-m -n -a| are the
> most interesting options).
> 

It looks like there are some additional errors there. I'll file some bugs when the tests finish running.
Comment 5 Christian Holler (:decoder) 2011-04-01 15:10:48 PDT
This might have been fixed by other commits from bhackett, I cannot reproduce. Alon, can you still reproduce this, and if so what options are you using?
Comment 6 Alon Zakai (:azakai) 2011-04-01 15:45:26 PDT
I can still reproduce a problem on latest jaegermonkey, with |-m -a -n|.
Comment 7 Jan de Mooij [:jandem] 2011-04-19 07:23:50 PDT
Both attachments work now with |-n -m|, |-n -m -a|, |-m -a| etc. Probably fixed by http://hg.mozilla.org/projects/jaegermonkey/rev/d78eef12a329

Alon, can you verify that we pass all emscripten tests now?
Comment 8 Alon Zakai (:azakai) 2011-04-19 09:58:41 PDT
(In reply to comment #7)
> Both attachments work now with |-n -m|, |-n -m -a|, |-m -a| etc. Probably fixed
> by http://hg.mozilla.org/projects/jaegermonkey/rev/d78eef12a329
> 
> Alon, can you verify that we pass all emscripten tests now?

I tried, but I can't build JM due to bug 644938.
Comment 9 Alon Zakai (:azakai) 2011-04-20 13:05:52 PDT
(In reply to comment #7)
> Alon, can you verify that we pass all emscripten tests now?

All emscripten tests now pass! :)
Comment 10 Alon Zakai (:azakai) 2011-04-20 13:15:56 PDT
I spoke too soon. They pass with |-m -a -n|, but I am seeing crashes with |-m -j -p -n|. Will file bugs.

Note You need to log in before you can comment on or make changes to this bug.