Last Comment Bug 646276 - Images are all blocky
: Images are all blocky
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on: 637852
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-29 16:58 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-02-22 15:01 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jeff Muizelaar [:jrmuizel] 2011-03-29 16:58:44 PDT
This shows blocky images with current trunk. It looks fine with FF 4. http://ie.microsoft.com/testdrive/Graphics/Transform2D/Default.html

This was not caused by the pixman update.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-03-29 17:49:35 PDT
How do we nominate bugs to block fx5 (in the "need to find what caused this and get rid of it" sense)?
Comment 2 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-29 21:09:03 PDT
It looks like the resolution clamping and automatic rerendering is broken...
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-30 04:25:07 PDT
The problem here is that we're creating an intermediate surface for a ContainerLayer and ContainerLayers don't know about resolutions. So the ThebesLayer's effective transform is just a translation, but then we scale the ContainerLayer's intermediate surface up a lot when we draw that.

I don't know how this worked in Firefox 4, I'm not aware of any relevant code that's changed.
Comment 4 Alice0775 White 2011-03-30 06:22:02 PDT
Probably I may misread STR and the issue(I don't understand "all blocky").

However, I notice one problem.
The image is blurred while image zoom-in. And then the image is repainted with correct resolution.

Regression window ;
Works:
http://hg.mozilla.org/mozilla-central/rev/488ea306526b
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100801
Minefield/4.0b3pre ID:20100801201130
Fails:
http://hg.mozilla.org/mozilla-central/rev/99807f92a67c
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100801
Minefield/4.0b3pre ID:20100801221929
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=488ea306526b&tochange=99807f92a67c
In local build on ubuntu10.04(from m-c repository):
build from 9a45bd27ec75 : fails
build from ed9773300a85 : works
Triggered by : 9a45bd27ec75	Matt Woodrow — Bug 505115. Use layers to render active 2D transforms. r=roc,dbaron
And Bug 604899 may be related, 

I'm sorry if I misunderstand it.
Comment 5 Jeff Muizelaar [:jrmuizel] 2011-03-30 09:00:44 PDT
Turns out when I saw this, I was running basic layers in FF4. So there isn't a real regression here. However, basic layers does look much better than accelerated layers.
Comment 6 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-03-30 13:39:14 PDT
Thanks Alice, you're absolutely right as usual!

I think BasicLayers is looking better because we choose to use component alpha for the transformed stuff (not sure why actually) and BasicLayers doesn't retain component alpha, so everything just gets rerendered from scratch all the time.

I think the right way to fix this is to move the resolution functionality out of the layer system altogether, as we've discussed in the past to fix other bugs. I'll do that in bug 646607.
Comment 7 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-23 23:14:39 PDT
Should have been fixed in bug 637852. Please retest on a nightly build.
Comment 8 Alice0775 White 2012-02-22 05:36:42 PST
I cannot reproduce on Firefox/10.0.2, 11Beta, Aurora12.0a2 and Nightly13.0a1 anymore.
Comment 9 Timothy Nikkel (:tnikkel) 2012-02-22 14:57:10 PST
Thanks Alice. Let's call it fixed then. Please reopen if that is not the case.

Note You need to log in before you can comment on or make changes to this bug.