Windows complete mars need updating now that we unpack the installer to create them

RESOLVED DUPLICATE of bug 660427

Status

RESOLVED DUPLICATE of bug 660427
8 years ago
7 years ago

People

(Reporter: Callek, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [blocking-sm2.2a1+])

(Reporter)

Description

8 years ago
On Trunk, windows now unpacks the installer to create the complete mars.

This is broken behavior for SeaMonkey as we store our extensions in the /optional/ directory of the package, so that the installer does not _require_ them.

We need to add a rule/steps to unpack /optional/ in addition to /core/ After Bug 313956.

This is blocking 2.2a1 but we do not yet have a flag for that. [Will also make complete updates of nightlies on 2.2 miss the extensions, but as its not our priority at the moment, I am living with that bustage]
(Reporter)

Comment 1

7 years ago
KaiRo, this is a 2.2 blocker for us, any chance you can *try* to come up with a solution....

(I can't think of one right now -- though perhaps Rail can suggest something)
(Reporter)

Comment 3

7 years ago
Actually looks like this stuff landed on m-2.0, and I am working on it in Bug 660427
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 660427
You need to log in before you can comment on or make changes to this bug.