WE does not see any text in text fields, WE and JAWS can't explore Firefox window with mouse emulation

RESOLVED WONTFIX

Status

()

Core
Disability Access APIs
--
major
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
These are very closely related, so covering them both here.
The assumption is that it is either the way we draw things on the screen now, even with Direct2D turned off, or we need the more sophisticated window emulation introduced for HAL/SuperNova in bug 612872 to be expanded for all ATs.

Let's try the second first and see if that helps.

Comment 4

6 years ago
Marco, is it still a problem? Should I start new try server build?
(Reporter)

Comment 5

6 years ago
Alex, if you could, yes, that would be great!

Comment 6

6 years ago
(In reply to Marco Zehe (:MarcoZ) from comment #5)
> Alex, if you could, yes, that would be great!

build will be available here http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/surkov.alexander@gmail.com-3397c3eff44a

Comment 7

6 years ago
Marco, ping?
(Reporter)

Comment 8

6 years ago
No, this does not solve the problem. Window-Eyes is still not able to see any text in textboxes with the try-server build.
(Reporter)

Comment 9

6 years ago
However, I was just notified by Window-Eyes of an upgrade to 7.5.2. This is a free upgrade to 7.5 users that solves this problem even for regular nightly builds. Suggest to close this one WFM and tell users to upgrade to the latest version of Window-Eyes. They usually are willing to upgrade anyway I'm told, so I think this is OK to do.

Comment 10

6 years ago
What about JAWS?
(Reporter)

Comment 11

6 years ago
JAWS had been using IA2 all along since JAWS 10 and therefore don't suffer from this issue.

Comment 12

6 years ago
wontfix per comment #9 and comment #11
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Comment 13

6 years ago
Out of curiosity, can JAWS/WE mouse emulation read the Firefox window now? My understanding is that this isn't related to IA2 for those screen readers.
You need to log in before you can comment on or make changes to this bug.