Closed Bug 646484 Opened 9 years ago Closed 4 years ago

Support IA2 on 64 bit Windows

Categories

(Core :: Disability Access APIs, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: davidb, Unassigned)

References

Details

I think all you need for this is bug 606080. Firefox doesn't need to register a proxy dll or similar like it does for ISimpleDom*, since it has been decided that this is the responsibility of the AT.
Depends on: 606080
Depends on: 649236
Now that there are official x64 builds of Firefox Developer Edition 38, this probably needs some attention again. Accessibility used to work in x64 builds of Firefox after bug 649236 was fixed, but now accessibility is pretty much completely broken.
Jamie, do you have a quick way to find out what exactly is broken? I can confirm that it is, but since some parts seem to work sometimes, it is hard to get a good picture from my end.
Flags: needinfo?(jamie)
IAccessible::accChild is failing with E_INVALIDARG for any id other than 0.
Flags: needinfo?(jamie)
(In reply to James Teh [:Jamie] from comment #4)
> IAccessible::accChild is failing with E_INVALIDARG for any id other than 0.

right, we fail to find an accessible by casted_to_int32 ID
I think this can be closed. Please reopen if necessary.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.