Enabling tab previews in the windows taskbar makes firefox windows(s) unmovable by external apps

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Kristian Tigersoul, Assigned: bbondy)

Tracking

2.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

When Previews in the windows taskbar is enabled the firefox window(s) cannot be moved by external applications using setwindowpos calls.

Reproducible: Always

Steps to Reproduce:
1. Enable Tab Previews in the windows taskbar option
2. Make a SetWindowPos call from an external app to MOVE a firefox window.
Actual Results:  
An additional EMPTY FRAME of a firefox window is put at the target destination, looking like a ghost (empty window). Weird behavior arises if you try to move this new ghost window and both the ghost and "real" window remain on screen.

Expected Results:  
The firefox window being moved correctly (answering the SetWindowPos call correctly)

The system is a multi monitor system and the window was moved to another monitor, this may affect the problem as this moves the window to "another" taskbar. UltraMon was installed but seems unrelated to the problem.
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32
Version: unspecified → 2.0 Branch
(Assignee)

Comment 1

7 years ago
The follwoing call works for me whether or not "Previews in the windows taskbar" is enabled.

HWND wnd1 = FindWindowW(L"MozillaWindowClass", NULL);
RECT rect;
GetWindowRect(wnd1, &rect);
SetWindowPos(wnd1, NULL, rect.left + 10, rect.top + 10, 0, 0, SWP_NOSIZE | SWP_NOZORDER | SWP_SHOWWINDOW | SWP_NOACTIVATE);  

I think you are probably obtaining the wrong window handle.
Also does the window move correctly when "Previews in the windows taskbar" is disabled?

Also please be careful because the window class MozillaWindowClass is also used by Firefox and other Mozilla applications.

Please re-open if you have specific code that you can paste which does not work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Assignee: nobody → netzen
You need to log in before you can comment on or make changes to this bug.