If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make each "condition" of the Search.pm WHERE clause into an object

RESOLVED DUPLICATE of bug 640045

Status

()

Bugzilla
Query/Bug List
--
enhancement
RESOLVED DUPLICATE of bug 640045
7 years ago
7 years ago

People

(Reporter: Max Kanat-Alexander, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
Right now we pass around a bunch of arrays and arrays of arrays to represent the WHERE clause conditions for Search.pm. In an attempt to start simplifying things, I'm going to make each of these "conditions" (basically, field-value-operator set) into an object. Although this may not seem like a big simplification at first, it's the first step in a larger simplification of Search.pm.
(Reporter)

Comment 1

7 years ago
This turned out to be too complicated and unnecessary to do by itself, so I folded it into bug 640045.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 640045

Updated

7 years ago
Target Milestone: Bugzilla 4.2 → ---
You need to log in before you can comment on or make changes to this bug.