background-color on :hover messes up image border

VERIFIED DUPLICATE of bug 61217

Status

()

--
minor
VERIFIED DUPLICATE of bug 61217
18 years ago
17 years ago

People

(Reporter: braden, Assigned: dbaron)

Tracking

({css1, css2, testcase})

Trunk
css1, css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

316 bytes, text/html
Details
(Reporter)

Description

18 years ago
I've been seeing this for a long time, but just recently bothered to narrow it
down. When a background-color has been set for :link:hover, the background color
shows through the lower part of the image border on mouseovers. In the test
case, moving the mouse over the image should have no visual effect.
(Reporter)

Comment 1

18 years ago
Created attachment 22119 [details]
Test case
Per CSS the background applied to the inline element should cover the content 
area of the inline element, whose size is not affected by its contents. The 
image is baseline aligned and so the bottom of the image does not touch the 
bottom of the content area of the inline element.

        +-------------+          TOP OF INLINE REPLACED CONTENT
        |x x x x x x x|
  ------|-x-x-x-x-x-x-|--------- TOP OF INLINE BOX CONTENT AREA
        |x x x x x x x|
  ______|_x_x_x_x_x_x_|_________ BASELINE
  ______________________________ BOTTOM OF INLINE BOX

The background you are seeing under the image's bottom border is covering the 
area where any descenders would go, if there was any text in the inline element.

However, that doesn't explain why the inline element's background (and borders
if you add any) are going in front of the inline replaced element's borders but
behind the inline replaced element's content.

David?
Assignee: clayton → dbaron
Severity: normal → minor
Keywords: css1, css2, mozilla1.0, testcase
QA Contact: petersen → ian
Marking dup of the bug that, when fixed, will turn this into just a line below
the image.

*** This bug has been marked as a duplicate of 61217 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.